Failed Nethsecurity Update

For the first time ever, i got errors after update attempt to the next incremental release of RC2:

Cannot retrieve updates status

Authentication error
Show details
AxiosError: Request failed with status code 401

The Roboot and shutdown tab says Something went wrong followed by Authentication error.

The router is rounting.

Since I cannot issue a reboot command from the GUI, so will force shutdown/restart from the device.

After rebooting, I still could not access functions in the UI from Microsoft Edge including reboot or logout, but using another browser, Chrome, was able to login. From there, I rebooted, and got the same error I got with Edge.

Explicitly signing out from the drop down menu in the upper right, and signing in, returns the system to correct operation, but rebooting again results in the error.

Hi Harry,

  • Which version are you currently running? It is written in the System card of Dashboard page, or you can run cat /etc/os-release | grep "VERSION=" in the firewall terminal
  • Can you spot any relevant logs inside /var/log/messages at the time of the error?
  • If you can reproduce the bug on Chrome, please open the browser console by pressing F12, then click the Network tab, then the failed network call, then the Preview tab, then take a screenshot (see below for an example)

1 Like

The release version is: NethSecurity 8 23.05.3-ns.0.0.5-rc2-65-g34d76bf

I had been updating every day (missing only 1 or 2), but have left this installed to follow your instructions.

Same failure on Chrome. After rebooting, errors appear. Logging out and logging in makes the errors disappear but a reboot brings them back.

Here’s my screenshot bur U don’t see the Preview option on my screen where you have the arrow 2nd from the top.

Since logging out and logging back in clears the problem temporarily, I went ahead and upgraded to: NethSecurity 8 23.05.3-ns.0.0.5-rc2-81-gf04a739 and it does not have the problem.


Andrea, I didn’t mean to ignore your request. I tried to do it, but in the error state, the pane you wanted me to take a screen shot of wasn’t accessible. I had several other complex things going on and chose to prioritize those over doing any more debugging. If the issue comes back I will do my best to provide more info. But NetSecurity performance and availability has been superb. It’s fast, and rebooting is very quick… I can upgrade an image while a movie is playing and nobody even notices.


Don’t worry, no further investigation should be needed; we already detected your issue and fixed it. That’s why you are not reproducing it anymore after the upgrade.