Execute files in samba shares

NethServer Version: 7.7.1908
Module: Fileserver

Hi All,

On samba shares i’ve set up I can set read/write or read only permissions but not executable, which I need. I’ve temporarily worked around this chmodding + x ibay root through ssh and recursively applying but I assume this could be overwritten by a reboot or upgrade.

I know I can apply a custom ibay share template through e-smith but was hoping for something that would behave a bit more like a NAS for example where execute permission is automatically grated to users who have write permissions.

If you have also a windows client at your network, you can set the permissions with RSAT tools.


1 Like

That’s brilliant just what I was looking for thanks for your help!


Sorry to be annoying just tried this and didn’t work the windows machine gives an error when applying permissions.
“Failed to enumerate objects in the container. Access is denied.”

I think you have also to do the following:


Thanks for the info I also found that if I create new share with nothing but the owner set then the windows acls work (persumably because they haven’t been previosuly set on the linux side?).

In either case I’ve just tested this and works fine now, (although I can;t see the access rights of users assigned from the linux side on windows but that’s no biggie)

I think so, because the problem seems to be the user mapping. But if you do it like @davidep wrote

it should also work if the share is created at the linux site.

Yes all seems good now thanks for your help.