Evebox problem on ARM 32

I’m using NethServer on ARM32 platforms.

I have problems with Evebox as below:

panic: runtime error: invalid memory address or nil pointer dereference
[signal SIGSEGV: segmentation violation code=0x1 addr=0x0 pc=0x1d7f0]

It seems caused by the bug in Go libraries for ARM32.

My hardware is an armv7l platform.

[root@fw ~]# cat /etc/system-release
CentOS Linux release 7.8.2003 (AltArch)
[root@fw ~]# rpm -qa | grep evebox

Somebody an idea?

Maybe you could try a binary from the project repo (https://github.com/jasonish/evebox/wiki/EveBox-RPM-Repository), or eventually, fill an issue there: https://github.com/jasonish/evebox/issues

Hi @mmspide,

Will try to reproduce this shortly. Odd thing is evebox, like most go programs, is staticaly linked. I other words it should not look for GO (runtime) lib’s as seems to happen.

Can you confirm this also happens if evebox is started with the systemd-unit?

You may want to edit etc/sysconfig/evebox first and set the “-v” vebose output flag first.

Also keep in mind the latest upstream versions (>0.11.1) are completely rewritten (in RUST IIRC) and not sure it is backward compatible…

Yes, I first tried to start it with systemd-unit.

[root@fw ~]# rpm -qa | grep evebox

Finally I solved my problem by changing how I run evebox as bellow:

sudo -u suricata /usr/bin/evebox server -v -D /var/lib/evebox/ --datastore sqlite CONFIG="-c /etc/evebox/evebox.yaml"

Either through systemd-unit I changed my /usr/lib/systemd/system/evebox.service and now it’s working well.

[root@fw system]# cat /usr/lib/systemd/system/evebox.service
Description=EveBox Server

#ExecStart=/usr/bin/evebox server $ELASTICSEARCH_URL $CONFIG $EVEBOX_OPTS
ExecStart=/usr/bin/evebox server -v -D /var/lib/evebox/ --datastore sqlite CONFIG="-c /etc/evebox/evebox.yaml"



Glad you are sorted out, still have to try to reproduce it :sleepy:

Your feedback diffidently will help once I do!

After many problems with Evebox specially with bookmarking configuration and many time crashes, it seems that my problem caused by the Evebox version related to bookmarking.

I updated my Evebox binary and it seems that my problem solved.

[root@fw system]# evebox version
EveBox Version 0.13.1 (rev 0dbcb12); armv7-unknown-linux-musleabihf

I should notice that my previous solution does not make Evebox work correctly, indeed it is not solution for my problem.