Ethernet does not function

NethServer Version: 7.2009
Module: Ethernet

I have encountered a very frustrating problem: Nethserver has cut all ethernet connectivity. I cannot access the GUI to troubleshoot; I am stuck in CLI.

The ethernet card is RTL8125, for which I have installed the correct driver. I had the ethernet connection working fine up to yesterday. The GUI alerted me to one of my DNS hosts not responding. It then cut out after I began a system backup to Backblaze.

The only change in my network is a new ISP. I switched to TekSavvy (a Canadian provider) in order to open port 25 for e-mail. That switch required me to get a DSL connection with PPoE access. Nethserver appears to have automatically conigured PPoE, despite it not being instructed to make such a connection.

So far, I have attempted to reset the network configuration using network-recovery. I have also manually disabled the PPoE connection and my wireless device, so that the ethernet device is the only available external interface. Neither of these actions helped.

When I run nmcli dev status, I get:
enp5s0 ethernet unavailable --

When I run db networks show, I get:



Ifconfig reads:

enp5s0: flags=4099<UP,BROADCAST,MULTICOM> mtu 1500
ether ******************* txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 (0.0 B)
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 16

I am going to be porting my installation off of the current computer to other hardware with a much older network card. This will hopefully solve my networking problem. In order to port the installation, however, I first need to resolve the network issue so that I don’t inadvertently wreck my new system.

Any ideas what could be done?

I personally doubt that that might happen.
NethServer7 is CentOS7 under the hood, and it does not reconfigure itself unless root (or configuration deployment) “tells” it to do.

I’d suggest you as first step to see which version of kernel are you using (uname -r) then look for troubleshooting on internet about RTL8125 and your kernel version.

I had problems with Realtek newtork cards and CentOS 7, were 1gbs NICs; I described how I solved here.

Some other people suggested to use ElRepo instead of others solutions, but your mileage may vary.
Consider that if you installed manually a driver… the thing has to be repeated at every kernel update. So maybe an automated solution might be a better path.