Errors or unusual behavior in the NS8 RC1

In this thread I will collect some unusual features about the behavior of the current NS8 RC1.

Basis system is a “proxmox VE 8.1.3” on Debian 12 (with NS8) as VM.

Debian 12 was installed by the installation medium “Debian-12.4.0-AMD64-NINTINST.ISO”.
The VM has two virtual disks (SCSI0, SCSI1), each for root file system and for the swap partition.
The VM is currently assigned 4GB.

I start by setting up the first node.

The desired IP address range and the desired port can be specified here (optionally).

The IP address range was adopted without complaint, but the own port was not (my port should be “60160”), the suggested port (55820) was used instead. There was no error message.

(I had already noted this behavior in another post)

Can the port be changed afterwards?
So far I can only find /etc/wireguard/wg0.conf, but that is probably not the only entry that needs to be changed.

I have set up a SAMBA AD and the email service.

When configuring the mail service, you notice that some settings are not adopted:
mail1 > Settings > Mailboxes > “Insert a prefix in the subject of spam messages”, here the desired prefix (junk) is not (permanently?) adopted. This is only noticeable when you access the area again.

For your information, my AD and mail configuration:
The Samba AD is based on an internal domain name (ad.intern.lan). The mail server was configured to an external domain name ( The AD works, so does the file sharing and also the mail service (I haven’t been able to check receipt yet).

1 Like

This section concerns SOGo. The installation went smoothly and so far there have been no problems in SOGo itself.

However, when configuring SOGo in the admin panel, settings are not applied:
sogo1 > settings > Advanced > “Auxiliary email account” - cannot be deactivated or does not remain deactivated. This is only noticeable when you open the settings again.

Not fixed in V 1.0.2

1 Like

This section concerns Nextcloud.

During setup, the LDAP (AD) was integrated directly. I like this,
According to the instructions, this would not be the case. It says there:

“As default, Nextcloud has its own user database. You can also connect the instance to an existing user domain: all users from the domain will be able to login with their own credentials. The built-in admin user is always enabled.”) "

In addition, the following things have been noticed so far:

Sending emails (status emails, etc.) from Nextcloud does not work. The facility at:
Administration Settings > Basic Settings > Email Server
does not lead to success. Neither via “sendmail” (worked in NS7) nor via SMTP (NS8 Mail). Various settings were tried, the mail server has a Letyencrypt certificate.

AD users do not have the correct email address stored in their profile settings.

The email addresses should have the pattern of the mail domain: “
However, the AD domain is stored: “name@ad.intern.lan”

Again Nextcloud.

The integration of an external memory (SMB Share from NS8) does not work (any authentication).

The registration data is correct and functioning of other devices in the local network.

This seems to be an error or an unfortunate translation of the NextCloud application.

The input fields of the configuration are misleading. If the address of the SMB server is separated into the host part (at host) and the domain part (at domain) it does not work. However, if the entire address is entered in the Host field, it works.

I can confirm the bug remains on ns8-sogo v1.0.5

1 Like