Error while doing automatic updates

NethServer Version: 7.9
Module: update

I am receiving mails about error when updating NS7:
Subject: Yum: Failed to check for updates on [servername]

Failed to check for updates with the following error message:
Failed to build transaction: php56-php-gd-5.6.35-1.el7.remi.x86_64 requires
php70-php-gd-7.0.29-1.el7.remi.x86_64 requires
php72-php-gd-7.2.4-1.el7.remi.x86_64 requires gd-last(x86-64) >= 2.1.1
php72-php-gd-7.2.4-1.el7.remi.x86_64 requires
php70-php-gd-7.0.29-1.el7.remi.x86_64 requires gd-last(x86-64) >= 2.1.1
php71-php-gd-7.1.16-1.el7.remi.x86_64 requires
php71-php-gd-7.1.16-1.el7.remi.x86_64 requires gd-last(x86-64) >= 2.1.1
php56-php-gd-5.6.35-1.el7.remi.x86_64 requires gd-last(x86-64) >= 2.1.1

any ideas how to troubleshoot?

check if remi.repo is enabled


Had the same issue on a clients server…

It was due to some leftover, older code for Remi…
These have been replaced for PHP 7.4, PHP 8.0 with different sources.


yum remove php56-php-gd -y
yum remove php70-php-gd -y
yum remove php71-php-gd -y
yum remove php72-php-gd -y
yum remove php73-php-gd -y
yum clean all

After this, the update will work - via web or via console.

My 2 cents


maybe from the virtual hosts from the old server manager that managed different source for php versions.

yes, these were - in some form - due to the older Server-Manager…
And maybe also from Nextcloud (Installed with Servermanager).

My 2 cents

Thnx Andy, that solved it for me

1 Like