Error when installing on VPS


(sky4all) #1

Hi guys I get this error:

nethserver-install
Starting installation process. It will take a while…

Installing base system…

Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
Error: Cannot find a valid baseurl for repo: centos-base
YumRepo Error: All mirror URLs are not using ftp, http[s] or file.
Eg. Invalid release/
removing mirrorlist with no valid mirrors: /var/cache/yum/x86_64/6/centos-base/mirrorlist.txt

Configuring system, please wait…

/usr/sbin/nethserver-install: line 45: /sbin/e-smith/signal-event: No such file or directory

You can access the Web interface at:
/usr/sbin/nethserver-install: line 51: /sbin/e-smith/db: No such file or directory
/usr/sbin/nethserver-install: line 52: /sbin/e-smith/db: No such file or directory

https://.:980/usr/sbin/nethserver-install: line 48: /sbin/e-smith/db: No such file or directory

Login: root
Password: <your_root_password>

Installation log can be found here: /var/log/nethserver-install.log

and there is log

Sun Mar 29 15:52:20 EDT 2015 Extra modules: nethserver-mail
Sun Mar 29 15:52:20 EDT 2015 Starting installation
Sun Mar 29 15:52:20 EDT 2015 rpm --import /etc/pki/rpm-gpg/*
Sun Mar 29 15:52:20 EDT 2015 yum --disablerepo=* --enablerepo=nethserver-base,nethserver-updates,centos-base,centos-updates install @nethserver-iso -y
Loaded plugins: fastestmirror
Setting up Install Process
Determining fastest mirrors
YumRepo Error: All mirror URLs are not using ftp, http[s] or file.
Eg. Invalid release/
removing mirrorlist with no valid mirrors: /var/cache/yum/x86_64/6/centos-base/mirrorlist.txt
Sun Mar 29 15:52:22 EDT 2015 /sbin/e-smith/signal-event system-init
Sun Mar 29 15:52:22 EDT 2015 yum install @nethserver-mail @nethserver-nut -y
Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
YumRepo Error: All mirror URLs are not using ftp, http[s] or file.
Eg. Invalid release/
removing mirrorlist with no valid mirrors: /var/cache/yum/x86_64/6/centos-base/mirrorlist.txt
Sun Mar 29 15:52:22 EDT 2015 End
Sun Mar 29 15:53:14 EDT 2015 Starting installation
Sun Mar 29 15:53:14 EDT 2015 rpm --import /etc/pki/rpm-gpg/*
Sun Mar 29 15:53:14 EDT 2015 yum --disablerepo=* --enablerepo=nethserver-base,nethserver-updates,centos-base,centos-updates install @nethserver-iso -y
Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
YumRepo Error: All mirror URLs are not using ftp, http[s] or file.
Eg. Invalid release/
removing mirrorlist with no valid mirrors: /var/cache/yum/x86_64/6/centos-base/mirrorlist.txt
Sun Mar 29 15:53:15 EDT 2015 /sbin/e-smith/signal-event system-init
Sun Mar 29 15:53:15 EDT 2015 End
Sun Mar 29 15:56:14 EDT 2015 Starting installation
Sun Mar 29 15:56:14 EDT 2015 rpm --import /etc/pki/rpm-gpg/*
Sun Mar 29 15:56:14 EDT 2015 yum --disablerepo=* --enablerepo=nethserver-base,nethserver-updates,centos-base,centos-updates install @nethserver-iso -y
Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
YumRepo Error: All mirror URLs are not using ftp, http[s] or file.
Eg. Invalid release/
removing mirrorlist with no valid mirrors: /var/cache/yum/x86_64/6/centos-base/mirrorlist.txt
Sun Mar 29 15:56:14 EDT 2015 /sbin/e-smith/signal-event system-init
Sun Mar 29 15:56:14 EDT 2015 End
Sun Mar 29 16:31:04 EDT 2015 Starting installation
Sun Mar 29 16:31:04 EDT 2015 rpm --import /etc/pki/rpm-gpg/*
Sun Mar 29 16:31:04 EDT 2015 yum --disablerepo=* --enablerepo=nethserver-base,nethserver-updates,centos-base,centos-updates install @nethserver-iso -y
Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
YumRepo Error: All mirror URLs are not using ftp, http[s] or file.
Eg. Invalid release/
removing mirrorlist with no valid mirrors: /var/cache/yum/x86_64/6/centos-base/mirrorlist.txt
Sun Mar 29 16:31:04 EDT 2015 /sbin/e-smith/signal-event system-init
Sun Mar 29 16:31:04 EDT 2015 End

I try run installation several times and I use some yum cleaning command but error didn’t go away.
I could use yum before running nethserver installation, after I run this script yum don’t work any more.
What could be the problem? I try install this to ipv4 NAT VPS with ipv6 addresses.


(Davide Principi) #2

Hi @sky4all, what is your VPS hosting?
Is the problem related to this?