Error when changing IPS policy

v69
ips

(Ralf Jeckel) #1

There’s a bug in the event file nethserver-pulledpork-apply.
In this file is the command /usr/bin/pulledpork.pl but the file in my /usr/bin-directory is pulledpork without .pl.
So I get an error when changing the policy. I copied the file to pulledpork.pl and the error was gone.
My system is NS6.9 final and fully updated.


(Michael Träumner) #2

@dev_team Could somebody have a look at this?

Thanks


(Giacomo Sanchietti) #3

I can’t reproduce the issue.

Installed packages:

  • pulledpork-0.7.0-2.noarch
  • nethserver-snort-1.0.3-1.ns6.noarch

The binary is named .pl:

[root@test6 ~]# rpm -ql pulledpork | grep bin
/usr/bin/pulledpork.pl


(Ralf Jeckel) #4

Hi Giacomo, thanks for answering.

Same packages installed at my side, but

[root@nethserver /]# rpm -ql pulledpork | grep bin
/usr/bin/pulledpork

?? Don’t know why.


(Giacomo Sanchietti) #5

Could you give me the output of: rpm -qi pulledpork ?


(Ralf Jeckel) #6
[root@nethserver /]# rpm -qi pulledpork
Name        : pulledpork                   Relocations: (not relocatable)
Version     : 0.7.2                             Vendor: Fedora Project
Release     : 2.el6                         Build Date: Thu 01 Dec 2016 12:26:58 AM CET
Install Date: Mon 02 Jan 2017 05:47:41 PM CET      Build Host: buildvm-ppc64-09.ppc.fedoraproject.org
Group       : Unspecified                   Source RPM: pulledpork-0.7.2-2.el6.src.rpm
Size        : 142350                           License: GPLv2+
Signature   : RSA/8, Thu 01 Dec 2016 12:27:38 AM CET, Key ID 3b49df2a0608b895
Packager    : Fedora Project
URL         : https://github.com/shirkdog/pulledpork
Summary     : Pulled Pork for Snort and Suricata rule management
Description :
Pulled Pork for Snort and Suricata rule management (from Google code).

(Giacomo Sanchietti) #7

As you can see, your pulledpork package is different:

  • mine: pulledpork-0.7.0-2.noarch
  • yours: pulledpork-0.7.2.2.el6

You installed it from EPEL not from standard community repo.


(Ralf Jeckel) #8

Sorry, I’ve overseen 0.7.0.2 and 0.7.2.2. Maybe to much party yesterday :blush:

But I don’t know why my installation is from epel.
I installed it from software center, not from CLI.
Nevertheless, I will remove IPS-Modul and reinstall it from Softwarecenter.

Thanks for your help.


(Ralf Jeckel) #9

O.k. it was my fault. My EPEL rep was enabled and so I think yum took the newer version from EPEL instead the one from nethserver-base.

Thanks again for your help.


(Giacomo Sanchietti) #10

You’re welcome :wink: