Error in SOGo activesync no update email

No error. Operation is regular only emails are not synchronized.

Others do? If so, could you try an account which works on an other machine please. Sowe can find out, if we have a problem with the client or the account.

NethServer Version: 7.6.1810
Module: SOGO
since yesterday i have a problem with activesync, sogo and ios systems. android and windows are okay.
i am not able to check by an ios system with acitvesync. error is wrong password. in the sogo log is written:
May 17 07:20:57 sogod [4368]: <0x0x55986cd19f30[SOGoDAVAuthenticator]> tried unknown authentication method: Basic (null) © May 17 07:20:57 sogod [4368]: “OPTIONS /SOGo/Microsoft-Server-ActiveSync HTTP/1.1” 401 33/0 0.001 - - 0 2019-05-17 07:20:57.292 sogod[4368:4368] ERROR: could not decode credentials (invalid base64 encoding) May 17 07:20:57 sogod [4368]: <0x0x55986cd19f30[SOGoDAVAuthenticator]> tried unknown authentication method: Basic (null) © May 17 07:20:57 sogod [4368]: “OPTIONS /SOGo/Microsoft-Server-ActiveSync HTTP/1.1” 401 33/0 0.001 - - 0.
Any Ideas?

1 Like

@stephdl Do you have an idea?

1 Like

I tried to install the account on another PC but I have the same problem.
It updates up to a few days ago and always remains in “update inbox folder” “all the signs are updated”, as if there were a block.

I add, the problems appeared after the installation of the latest Nethserver updates.

Are there accounts which work?

no changes recently, for my best knowledge

how many users have you at the same time ?

you need between 25 to 45 MB per users and we allow 512 in /etc/sogo/sogo.conf

SxVMemLimit = 512;

to increase

config setprop sogod SxVMemLimit 1024
signal-event nethserver-sogo-update

the number of workers needs to be increased too

There are about 30 accounts all working. Currently there are only 2 that present this problem.

There are about 30 users accessing the mail server. Does the value you indicate (SxVMemLimit) increase without receiving error messages in the logs?
Fine tuning has been performed.
Is there no way to see if the set values ​​(WOWorkersCount, SOGoInternalSyncInterval, etc) have to be retouched?

Ok only two get the issue and not all people alternatively… Could it be restricted to windows sucks?

It may be, but on three different PCs the problem occurs. On two PCs the same account, on the third different account.

All users are using the same SOGo Client?
If not, which are used from the working ones and the not working ones?

All outloo 2016 and one outloo 2019. Those with sync problems use outloo 2016 and outloo 2019 (and an outloo 2016 as a test).

Are you using the SOGo-supported connector?

No, i use ActiveSync, not imap+caldavsynch.

I raised the value SxVMemLimit to 2048 and increased the number of workers and now everything is working again. I also deleted a user’s cache using this command

sogo-tool manage-eas resetdevice

Previously I had also increased this SOGoMaximumSyncResponseSize to 5172 but he hadn’t solved the problem

thanks to all of the support


Could you mark the topic as solved please.

Hi! I have the same situation. Didn’t find a solution?