Error in remote management of RSAT on AD domain host

Neth7 7.9

Hi everyone, I wanted to bring you a rather strange problem. I joined a windows 10 pro and in the user management acitve directory of neth7, if I go to the computer manager section, I will receive the error that it is not possible to connect to the computer due to windows firewall or not available on the network. It was a problem that I knew, however connecting in the neth7 dns (rsat) management I noticed that in the domain zone its record was missing. After adding it, it started working again. The current configuration is:
AD provider
domain ad.internal2.lan
dhc managed by neth7 internal2.lan
The machine that performed the join has the domain name and the ip in dhcp with the name
I wonder why it was not registered on the AD dns like the others.
I hope I was clear in submitting the situation.
If I add the ptr record to the zone, the problem is solved.
Furthermore all the machines have neth7.internal2.lan as dns and not!

You may try to register the DNS on the Win 10 client on command line with

ipconfig /registerdns

This should update the DNS entry on the server or show an error in event viewer.


IPv6 could be a problem too, maybe your router has DHCPv6 enabled?
You may disable IPv6 in Windows network settings and rejoin the client.



Hi MArkuz, I tried as you wrote me and it works! To see if it was actually registered correctly I removed the static clients that I had manually entered in the dns area and after giving the command ipconfig / registerdns I found them in the list dynamically, so it works. I don’t have nessn dhcp6 at least i think, the server that distributes ip is neth7. I do not understand . I refer you to my configuration already exposed in the post a few days ago.

DHCP on AD or not?
I saw that in this link you sent me it is recommended to change the management of the neth dns to the domain controller, which is always neth7 in the br0 interface of the AD.

It shouldn’t matter. Neth DNS has a redirection to the NSDC DNS.

In /etc/dnsmasq.conf there’s following line to point to the container for your AD domain.


1 Like

Anyway thanks for solving the problem (to be honest I looked for some faq but nothing!). Congratulations to you and the nethserver community!

1 Like

Hi, regarding the old XP clients joining with nethserver the DNS registration didn’t work dynamically. I had to assign a stastic ip and insert it in the AD dns manually, done this through rsat you can also manage xp sp3.

1 Like