Error creating empty group with nethserver-dc

Hi all,
I have a problem creating a new group with nethserver-dc installed.
In particular, the problem arise when I create a group without any members from the web interface.
At the end the group is created and added to the list.
Has anyone had the same error ?

Scenario:

  • NS 7 Beta 2 updated
  • nethserver-dc-1.0.3-1.ns7.x86_64

How to replicate:

  • go to the web interface and to “Users and groups”
  • create a new group leaving empty “Members” field
  • click “SUBMIT”

Error from web gui:
“Task completed with errors # (exit status)”

Error from /var/log/messages:

Sep 12 14:32:03 ns7beta2-1 esmith::event[2065]: Event: group-create somegroup
Sep 12 14:32:05 ns7beta2-1 esmith::event[2065]: Added group somegroup
Sep 12 14:32:05 ns7beta2-1 esmith::event[2065]: ERROR(exception): Failed to add members "" to group "somegroup" - Unable to find "". Operation cancelled.
Sep 12 14:32:05 ns7beta2-1 esmith::event[2065]:  File "/usr/lib64/python2.7/site-packages/samba/netcmd/group.py", line 227, in run
Sep 12 14:32:05 ns7beta2-1 esmith::event[2065]:    add_members_operation=True)
Sep 12 14:32:05 ns7beta2-1 esmith::event[2065]:  File "/usr/lib64/python2.7/site-packages/samba/samdb.py", line 274, in add_remove_group_members
Sep 12 14:32:05 ns7beta2-1 esmith::event[2065]:    raise Exception('Unable to find "%s". Operation cancelled.' % member)
Sep 12 14:32:05 ns7beta2-1 esmith::event[2065]: [ERROR] Failed to add members to group somegroup
Sep 12 14:32:05 ns7beta2-1 esmith::event[2065]: Action: /etc/e-smith/events/group-create/S40nethserver-dc-group-create FAILED: 3 [1.566072]
Sep 12 14:32:05 ns7beta2-1 esmith::event[2065]: Action: /etc/e-smith/events/group-create/S90nethserver-sssd-clear-cache SUCCESS [0.111563]
Sep 12 14:32:05 ns7beta2-1 esmith::event[2065]: Event: group-create FAILED
4 Likes

Thank you for reporting this, @alep!

Fix released on

nethserver-dc-1.0.4-1.ns7.x86_64.rpm

3 Likes

I had this in this thread Failed to get machine PTY: No such file or directory

But I though this should be this way.

1 Like

Just installed from Software center -> Updates.
It works!

Thank you @davidep !

3 Likes

Me, too. No more error with nethserver-dc-1.0.4 when creating an empty group.

Perfect work @davidep . Thank you!

3 Likes

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.