Error after update recreating AD

centos
v7
activedirectory

(Gordon) #1

NethServer Version: 7.4
Module: sssd
Hi
We have reapplied the update to 7.4 and done the fstab /defaults etc but had

Failed to initialize credentials using keytab [MEMORY:/etc/krb5.keytab]: Preauthentication failed. Unable to create GSSAPI-encrypted LDAP connection.

So removed the AD domain and reinstalled using ad.xxxxx.xxx.xx for the DNS domain name and XXXXX for the Netbios name. All good the installation ask us to set the admin user. But the domain (RHS) is now only xxx.xx.

Got the same result twice. The config show sssd is good

sssd=service
AdDns=192.168.35.2
LdapURI=
Provider=ad
Realm=SRV.COMPSOS.COM.AU
Workgroup=COMPSOS
status=enabled

It looks like a script somewhere is taking off the first two segments of the domain name. The configuration db has the right answer for DomainName but the command config show DomainName is the abbrievated version.

Users and Groups come up as @xxx.xx.
How can we get the domain name corrected? TIA


[SOLVED] CentOS 7.4 (1708) - Shared folder access
(Gordon) #2

Found the culprit. The servername had become just the domainname so when the AD was constructed it added ad prefix dropped the next section as being the hostname


(Giacomo Sanchietti) #3

I’m not getting it.

Did you found a workaround?


(Gordon) #4

Hi @giacomo
Yes. The servername as shown in the Server manager had dropped the hostname and left just the domainname. Correcting that then reinstall the AD “worked” but not completely. Still unable to join or operate the AD Domain since the update. Just trying to get more details from the system now.