Error after changing date and time settings

virtualization
v7

(David Gordon) #1

NethServer release 7.5.1804 (final)
Date & Time

I’m still having trouble getting Nethserver to keep time. I’ve tried all the tricks suggested by The Internet to make VirtualBox keep time but its still out.

This morning Nethserver said it was 0731 on Wednesday the 18th. More than two days out! My Date & Time was set using manual settings (as that was a suggestion) so I thought I’d try NTP.

On clicking ‘confirm’ I went back to the Dashboard and got a popup windowforbidden

When I dismiss this I am logged out and taken to the login window.

So two problems. One I don’t know if it can be solved, how to keep time correct in Nethserver using VirtualBox on a Mac and what’s happening when I change the Date & Time setting?


(Marc) #2

the time problem happens from cold boot or booting from a saved running state?


(David Gordon) #3

Not sure. I was about to save my running state then quit VB, reboot the Mac and see what happens. Stay tuned!


(David Gordon) #4

Rebooted my Mac and cold started Nethserver on the VM. Been running four minutes and already the time has slipped back a couple of minutes.

Time on the Mac host is correct!

NS set to ‘manual settings’ in Date and Time.


(Markus Neuberger) #5

Maybe you are missing the guest additions:

yum install dkms
yum install virtualbox-guest-additions

https://www.virtualbox.org/manual/ch04.html#idm1873


(David Gordon) #6

No I don’t think so. I even updated them today! I followed these https://fitzcarraldoblog.wordpress.com/2016/07/01/how-to-stop-the-clock-in-a-virtualbox-virtual-machine-from-drifting/ instructions but its not worked for me.