Email2 installation failure due to existing nethserver-mail-common module

v7
mail2
mail

(harry) #1

I have had previously installed and removed the old email package, but had never configured it. Attempting to install email2 produced the following error messages:

Mar 10 16:36:53 roy pkgaction[5452]: install: @nethserver-mail2, nethserver-roundcubemail, nethserver-getmail
Mar 10 16:37:00 roy pkgaction[5452]: [YumRPMCheckError] [u’ERROR with transaction check vs depsolve:’, ‘nethserver-mail-common conflicts with nethserver-mail2-common-2.0.0-1.ns7.noarch’]

I then tried reinstalling email and removing it, which reports:

Mar 10 16:44:14 roy pkgaction[8320]: remove: @nethserver-mail, nethserver-mail-filter, nethserver-mail-server
Mar 10 16:44:15 roy pkgaction[8320]: update:
Mar 10 16:44:15 roy pkgaction[8320]: install:
Mar 10 16:44:16 roy yum[8320]: Erased: nethserver-mail-filter-1.4.4-1.ns7.noarch
Mar 10 16:44:16 roy yum[8320]: Erased: nethserver-mail-server-1.11.0-1.ns7.noarch

but it does not remove nethserver-mail-common, so trying to install email2 produced the same error.

In the list of installed RPMs, these two modules appear:
|nethserver-mail-common|1.6.6|1.ns7|
|nethserver-mail-smarthost|1.0.0|1.ns7|


(Markus Neuberger) #2

Hi @harry,

you may try to yum swap the packages:

yum swap \
    -- remove nethserver-mail-{common,filter,server} \
    -- install nethserver-mail2-{common,filter,server}

http://docs.nethserver.org/en/v7/mail2.html#upgrade-procedures


(Eddie Atherton) #3

I think the issue is that Package Manager only removes the named package and not any other others that were installed as requisites.

Cheers.


(harry) #4

@mrmarkuz Thank you. My guess is you are both correct. Since I wasn’t actually using the mail server since a clean install, I figured I could ignore all the instructions about upgrading.

@EddieA Thank you. Very helpful.

Is it possible that nethserver-mail-common (others?) is included in the base Nethserver installation or something else I installed, rather than being installed by the mail server package?

But it is odd that nobody else has complained. One noteworthy thing is I did a clean install from the current Nethserver ISO and maybe others upgraded from an earlier version. I have too many other things on my plate to go investigate, but I am sure somebody here knows.

More details that may help somebody:
My messages log says:

Mar 10 16:12:24 roy pkgaction[2778]: remove: @nethserver-mail, nethserver-mail-filter, nethserver-mail-server, nethserver-p3scan
Mar 10 16:12:24 roy pkgaction[2778]: update:
Mar 10 16:12:24 roy pkgaction[2778]: install:
Mar 10 16:12:26 roy yum[2778]: Erased: nethserver-p3scan-1.1.3-1.ns7.noarch
Mar 10 16:12:26 roy yum[2778]: Erased: nethserver-mail-filter-1.4.4-1.ns7.noarch
Mar 10 16:12:26 roy yum[2778]: Erased: nethserver-mail-server-1.11.0-1.ns7.noarch

But a search for installed packages with the string: mail shows:

nethserver-mail-common
nethserver-mail-smarthost

and several others without “nethserver” in the module name:

getmail, mailcap, mailx
perl-Mail-DKIM
perl-Mail-RFC822-Address
perl-Mail-SPF
perl-MailTools
procmail

and, there are two links in the left side Menu labeled:

Mail queue
Email

My complete list of packages installed:
Backup
Bandwidth monitor
Basic firewall
Deep packet inspection (DPI)
FTP server
Intrusion Prevention System
MariaDB (MySQL) sdeerver
Nextcloud
OpenVPN
Statistics
UPS support
Virtual machines manager
Web proxy