Email - smarthost issue

smarthost
mail
v7

(Richard Neil) #1

I’m running the current version of Nethserver as a DC, fileserver and mail server only at present. I have a registered domain name and forward email from the provider to my ISP and that works fine and mail is being downloaded though more spam is coming through than with the old mail server: I’ll tune that later. I had to retire the old server as it was truly ancient running on an equally old OS though utterly reliable.

The other change is that the old server worked with a xxx.loc domain and the NS is running a subdomain of my registered domain as recommended in the documentation.

What is not working is smarthost. I transferred the settings exactly except NS sends encrypted only and it did not work due to an authentication error. The ISP concerned was totally useless for support forcing a long planned ISP change. However I’m getting the same result with the new ISP to suspect it may be NS issue. The error message is “SASL authentication failed; server mailhost.zen.co.uk[212.23.1.11] said: 535 Incorrect authentication data”. Previous ISP error is similar “SASL authentication failed; server smtp.dsl.pipex.com[212.74.114.24] said: 535 5.7.0 K3SIdvOXQGpV6 Authentication Credentials Invalid (TT300))” That was despite the fact I could log into their webmail portal to know the name and password were fine.

Any ideas what might be going wrong?

Richard


(Richard Neil) #2

Solved. Resetting the password with the ISP resolved this. Since I copied and pasted the same password last time and this from a password manager I’m not sure what went wrong but at least it is working.