Email setup questions

email
v7

(Dan) #1

NethServer Version: 7.5
Module: base system

I’ve set up a second Neth instance (phabricator.mydomain) for testing purposes (e.g., to play with Phabricator), while my first instance (neth.mydomain) is used for main web/mail/Nextcloud/etc. I don’t really want to set up a mail server on the second server, but I do want to get admin emails sent to admin on the first machine. Not quite sure how I should set this up, though.

So far, I’ve configured the second server to use the first as a smart host. I created a user account on the first server just for this purpose, and entered its username and password in the smarthost configuration on the second. But when I use mutt on the second server to try to send email to admin@mydomain, it doesn’t go through. Clearly I’m missing something here–what would be the best way to configure this?


(Dan) #2

I see the tag of “accounts-provider” has been added. I’m not sure what this question has to do with the accounts provider, but the second server is configured with remote LDAP, using the first as its source.


(Marc) #3

OK, removed the tag.


(Dan) #4

Any ideas?


(Filippo Carletti) #5

Your setup should work. You may probably do it without a smarthost, but its presence shouldn’t hurt.
I think that you need to inspect /var/log/maillog to find some clues.


(Dan) #6

Wouldn’t that end up trying (and failing) to deliver everything locally? If not, I’d just as soon have the simpler setup, but I figured that would be a problem since both servers belong to the same domain.

Silly me, yes, should have checked the logs. It’s looking like auth failures, which shouldn’t be happening, but it’s something I can work on.


(Filippo Carletti) #7

No, unless you installed the mail-server (which is optional).
That’s why I said “you may…”.


(Dan) #8

No, didn’t do that. Looks like the simple answer, then, would be to just disable the smarthost–I’d figured I needed it. Disabled the smarthost, and now it’s working. Thanks!