Ejabberd 18.06 bug or issue

ejabberd

(Gerald) #21

Hello @stephdl!

I hope I do not stress you so much :wink:

Can you support you?
Alpha or beta test?
Translation?

A bottle of delicious wine?

best regards
Gerald


(Stéphane de Labrusse) #22

what client do you use please :slight_smile:
thank for your support, I will soon have an alpha, but please, please do not test on real server.

For example I am not sure if persistent room will survive, something to test for example


(Gerald) #23

On the smartphone, conversation
and on the computers I PidGin and my wife Gajim


(Stéphane de Labrusse) #24

yum install nethserver-ejabberd --enablerepo=nethserver-testing

you should have ejabberd workable, please do not test directly on your server.

If all is workable for you, then I would be pleased that you test the upgrade from 16.01 with some persistent rooms and users.


(Giacomo Sanchietti) #25

Tested on a vm on on a production machine (AD only) for now.
No problems so far.

Come on @gerald_FS @greavette it’s now time to give help to our mighty Stéphane!


(Markus Neuberger) #26

Tested on a VM with LDAP as account provider. I tried pidgin and miranda as clients and it works as expected. Admin interface works too.


(Giacomo Sanchietti) #27

Can someone explain me how to test the S2S feature?

/cc @greavette @tboston @stephdl


(Stéphane de Labrusse) #28

new version is good on samba AD, I can retrieve the list of users and the panel got you modification, you could upgrade your prod server :smiley:


(Gerald) #29

S2S function does not work for me …

Can not send to my colleagues who run their own Jabber server, with the old version is when you enable the function.

To test you can use my test account:
jabbertest@nandlnet.de

Will be deleted after the test phase :wink:

There was a problem during the update with dependencies, had to create another hand.


(Gerald) #30

Sorry @stephdl that I was so indisposed, but I had some very important private stuff to do.


(Giacomo Sanchietti) #31

Thank you for testing! I have exactly the same issue.

I will use your contact for testing. My test user is: richard@nethserver.net


(Giacomo Sanchietti) #32

I think I’ve found the solution.

Please try the latest rpm from testing:

yum --enablerepo=nethserver-testing clean all
yum --enablerepo=nethserver-testing update nethserver-ejabberd

(Gerald) #33

great it works!

Configuration, encryption, external networks!

Installation also works, update and new install.

Juhuuuuu !!
Thank you @stephdl @giacomo - now comes the fine sanding :wink:


(Gerald) #34

So, after a week of operation on two NS machines, I can say - just fine!

@stephdl Everything works! Wonderful!

However, I would have three comments / change requests:

  • An input field in which you can set the language
  • HTTP file transfer (mod_proxy65) - File transfer does not work, messages and so on go, but there is no transfer
  • Release eJabberd for specific groups only

But even if this was not possible, a good feeling if you can communicate about your own software / hardware :wink:

greetings
from sunny Bavaria!

Gerald


(Tony Boston) #35

@giacomo great! do you see that in the next round of updates to nethserver?


(Gerald) #36

Hello,

I just put the mod_proxy65 module of eJabberd into operation, so now a file transfer can take place.

This was pretty much the last feature I had missed.
VII. Is it still possible to disable this via the GUI if some people do not want or need it?

I have that
/etc/e-smith/temples/etc/ejabberd/ejabberd.yml/85Modules
added the following entry at the end:

  mod_proxy65: \ {\}

In the second step I assigned the port 7777 to the eJabberd service.

config setprop ejabberd TCPPorts 5222,5223,5280,5269,7777

Restart the services and apply the changes:

signal-event ejabberd-update
signal-event firewall-adjust

And it works!

Big thanks go to @stephdl because he has created for us the implementation of the current Versin!
Without his knowledge and motivation, I would probably still cry


(Giacomo Sanchietti) #37

The package still needs some work on the archive message part. @stephdl will look into it after its holidays :slight_smile:

This should be necessary only for non-LAN clients. Am I right?
Reading the official documentation, it seems mod_prox65 needs a bit of configuration for the security part, for example the authentication is disable by default.
I’d leave this part to next round of updates and give priorities to the exiting modifications.


(Stéphane de Labrusse) #38

Please a brave to test the new ejabberd rpm https://github.com/NethServer/dev/issues/5537#issuecomment-414733758

@gerald_FS @tboston are u interested ?


(Giacomo Sanchietti) #39

Released.


(Gerald) #40

Juhuu - I am thrilled!

Finally it works like I imagine, thanks @stephdl !