Duplicity backup to Nextcloud - Disk usage 100%

NethServer Version: NethServer release 7.9.2009 (final)
Module: Data Backup

I use Nethserver’s Data Backup and make a backup every night to a Nextcloud directory on another server using Duplicity.
After the backup, Duplicity sends an email about the backup and indicates the disk usage at the end of the report.
The following was in the report tonight:

Disk Usage:
Size Used Available Use%
332.80 GB 332.80 GB - 100%

This really annoys me because I don’t know which server it applies to, the Nethserver or the Nextcloud server?

Nethserver’s disk usage looks like this:

df -h
Filesystem Size Used Avail Use% Mounted on
devtmpfs 16G 0 16G 0% /dev
tmpfs 16G 36K 16G 1% /dev/shm
tmpfs 16G 901M 15G 6% /run
tmpfs 16G 0 16G 0% /sys/fs/cgroup
/dev/mapper/centos-root 922G 357G 566G 39% /
/dev/md126 973M 266M 708M 28% /boot
tmpfs 3.2G 0 3.2G 0% /run/user/0

Nextcloud’s disk usage looks like this:

df -h
Filesystem Size Used Avail Use% Mounted on
udev 16G 0 16G 0% /dev
tmpfs 3,2G 1,4M 3,2G 1% /run
/dev/md0p1 915G 513G 356G 60% /
tmpfs 16G 0 16G 0% /dev/shm
tmpfs 5,0M 0 5,0M 0% /run/lock
tmpfs 16G 0 16G 0% /sys/fs/cgroup
/dev/sda1 1,1G 6,1M 1,1G 1% /boot/efi
/dev/loop1 62M 62M 0 100% /snap/core20/1611
/dev/loop0 56M 56M 0 100% /snap/core18/2667
/dev/loop2 92M 92M 0 100% /snap/lxd/24061
/dev/loop3 264M 264M 0 100% /snap/nextcloud/33054
/dev/loop4 50M 50M 0 100% /snap/snapd/17950
/dev/loop5 64M 64M 0 100% /snap/core20/1778
/dev/loop6 68M 68M 0 100% /snap/lxd/22753
tmpfs 3,2G 0 3,2G 0% /run/user/1000

Did you run out of disk space somewhere or is Duplicity calculating incorrectly?

Could someone help me, because it wouldn’t be good if the save stopped or if one of the disks was full and I didn’t notice it…

Thank you for your help.

It seems you used snap to install Nextcloud and it has limited disk space.

1 Like


I don’t understand what happened during installation. I installed Ubuntu 20.04 and downloaded Nextcloud-21.0.1.zip from download.nextcloud.com. I updated it after installation, but I don’t know how it became snap… Maybe I downloaded the wrong one?

The output of lsblk -f is the same for me as in the link you attached:

lsblk -f
loop0 squashfs 0 100% /snap/core18/2667
loop1 squashfs 0 100% /snap/core20/1611
loop2 squashfs 0 100% /snap/nextcloud/33054
loop3 squashfs 0 100% /snap/snapd/17950
loop4 squashfs 0 100% /snap/lxd/22753
loop5 squashfs 0 100% /snap/lxd/24061
loop6 squashfs 0 100% /snap/core20/1778
├─sda1 vfat 124A-CD51 1G 1% /boot/efi
└─sda2 linux_raid_member ubuntu-server:0 a5e6e3e2-bdf1-9724-c16e-c7eb9af4f60f
└─md0p1 ext4 c6dd3ed5-7259-42e1-85c9-7b7df199855f 355,2G 56% /
├─sdb1 vfat 1269-C4D0
└─sdb2 linux_raid_member ubuntu-server:0 a5e6e3e2-bdf1-9724-c16e-c7eb9af4f60f
└─md0p1 ext4 c6dd3ed5-7259-42e1-85c9-7b7df199855f 355,2G 56% /

The size of the md0 array is 915 GB, of which 355 GB are free, loop2 squashfs is 100% used, there is no free space on it.

Unfortunately, I don’t understand what should be resized and how? Should loop2 be resized? I can resize an LVM, but how can this be done? So far I can’t find a solution for this using Google…

Thanks for your help.

Ubuntu is silently converting traditional applications into snaps (if snaps for that application are available). Don’t know if that’s your case as I guess web apps installed manually are not affected, unless you installed the snap version.

On Ubuntu you can check it with:

snap list | grep -i nextcloud

But from the the df -h output looks like it is a snap:

Otherwise, the issue could be the assigned storage quota on Nextcloud… but doesn’t seem to be the case.

Snap apps are sandboxed so they always show 100% used. Their settings and data are actually stored in your home user folder. (source)

You can check what space is taking the snap with just lsblk (without -f):

lsblk |grep nextcloud

For nextcloud-snap data you can look at:



1 Like


Thank you for your help. I am at a loss when faced with this problem.

I downloaded the zip file and extracted it to the /var/www directory. After that, I set up Nextcloud manually and installed the data directory under /opt/nextcloud.
Nevertheless, /snap/nextcloud is created and the snapd service is running.

I stopped running nextcloud snap with “snap stop nextcloud” and stopped snapd with “systemctl stop snapd”.

I started the data backup to Nextcloud on the Nethserver, now it runs and writes the backup to the designated directory of /otp/Nextcloud…

Now I’m waiting for the backup to run and to see how much disk usage is in the report.
It seems to me that Nextcloud is installed both normally and via snap, but the directories under snap are empty.

What could this be?

Hi @steve

As you chose to install NextCloud on Ubuntu, not on NethServer, and it’s your Ubuntu installation giving you issues, why not ask on the Ubuntu forum?

We NethServerians don’t like using non open source software, like snap. The source for the snap store (server side) is NOT available…

My 2 cents


sorry but I needed urgent help and I’m not a member of the ubuntu forums, so I thought maybe someone could help me here quickly.

Unfortunately, it is not advisable to save Nethserver data to Nextcloud running on Nethserver. I think you understand this…

Therefore, I had to quickly create an auxiliary server just for Nextcloud, and the fastest solution for this was the Ubuntu installation. This was necessary because I had not yet completed the real backup server because there were HDD problems with it. Tomorrow I will get new HDDs and then this problem will be solved.

I promise I won’t burden the forum with such problems next time, but I had no one to turn to.

Thank you for the help of @mrmarkuz and @dnutan, based on the suggestions, I managed to solve the problem temporarily by disabling snap and thus saving works. The cause of the problem is currently unknown to me, but only tonight’s save should work on this server.

Thanks for all the help.

I think that this affirmation need some motivations… :slight_smile:

Backup on USB or SMB was not an option?


I think he was forced to:

“had to” - the poor guy had no choice…
maybe forced at gunpoint…

This reasoning also is pure bunk (B.S. …)

“Unfortunately, it is not advisable to save Nethserver data to Nextcloud running on Nethserver. I think you understand this…”

Any reasonable person would simply use a USB, or SMB or NFS network share - any host capable will do. No normal person would set up Nextcloud just to backup another server!
Nextcloud as backup target only makes the whole backup twice as long (slow), and introduces complexity for no sensible reason. NextCloud only offers disadvantages as backup target, not a single advantage!

Obviously too complex for our user here, and was too lazy to ask in Ubuntu’s forum…

My 2 cents


You have a good sense of humor…

My backup server is not working due to a HDD problem, I saved its data on a USB over the weekend. I don’t have another USB drive at home for backup.

Unfortunately, the two problems appeared at the same time, so I had no better idea. I could have chosen a different solution, I could have installed FTP or Samba, but I would have kept Nextcloud for other purposes later on, so I chose this.

Now I’m familiar with Ubuntu, although I don’t like it, but it was installed, so Nextcloud was installed on it.
Fortunately, there was someone who wanted to help and did so, so I found the cause of the problem and the solution. I thank them for their help.

I apologize once again and the topic can be closed from my side.

Hi @steve

Humor is if one can still laugh about it!

I was just traying to inform you that using NextCloud (I’m a big fan of NextCloud on NethServer) as Backup is very slow and inefficient… NFS is for linux the fastest, SMB is also quite usable. FTP? That’s outdated! It’s fast, OK, but - FTP modifies the time/date stamp on all files (normally).

My 2 cents



Thanks for your comments about the save, I agree with you.

But at the moment I didn’t have a working server and I don’t use NFS. Samba, on the other hand, is only available on the Nethserver, so it is not advisable to save on it.

I am constantly working on placing the Nethserver in a server hosting, and for that I would need a backup server accessible from the Internet where the backups from the Nethserver can be uploaded. This could be a Nextcloud solution in the future, because it has proven itself in the local network. This could also be Nextcloud installed on Ubuntu, but it still doesn’t work as it should, see snap problem. Another solution is to install a Nethserver at home and save to the Nextcloud running on it from the Nethserver operating in the server hosting.

I just received your new HDD and I’m going to start uploading the data on my backup server and then I’ll continue solving the problems.


1 Like