Dummy interface on 7.6.1810

NethServer release 7.6.1810 (final)
create a dummy interface as per Dummy Interface (virtual NIC)
the newly created dummy NIC cannot be used, system asks to release the role.
The only workaround I have found to have a virtual nic is to create a new VLAN under the dummy itself an promote the VLAN NIC to green role.
Is it by design or just a bug?

Maybe this helps https://wiki.nethserver.org/doku.php?id=virtual_network_interface&s[]=dummy

iI will give it a try, thanks

Hello,
I tried to follow the instructions on the link you provided me

unfortunately it doesn’t work, see my attachment

the dummy interface doesn’t use any MAC address and cannot be enabled. I have to create a VLAN on dummy and enable that one to work as green.

What menu are you using pls?
This is my listing is ‘diagnostics’

(not very clean for I have OpenVPN running

sorry…I realized that I left the same address on red and on green… btw the problem is present with correct setup also

Can you show your ‘diagnostics’ dummy entry?

here’s it
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: ens18: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether d2:90:41:fb:fd:85 brd ff:ff:ff:ff:ff:ff
inet 192.168.19.20/24 brd 192.168.19.255 scope global ens18
valid_lft forever preferred_lft forever
inet6 fe80::d090:41ff:fefb:fd85/64 scope link
valid_lft forever preferred_lft forever
3: dummy0: <BROADCAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
link/ether 10:00:01:02:03:04 brd ff:ff:ff:ff:ff:ff
inet 10.1.2.1/24 brd 10.1.2.255 scope global dummy0
valid_lft forever preferred_lft forever
inet6 fe80::1200:1ff:fe02:304/64 scope link
valid_lft forever preferred_lft forever

So it does have the correct set MAC address. It is just the Nethserver inner detection that can not cope with dummy interfaces yet.

But what are trying to achieve and within what menu?

I’m trying to have the dummy interfaces setted up as green and the physical one as red.
Nethserver is not working at this moment becasue dummy is not recognized and all I can do is just release its role

This is the important part for you:

https://wiki.nethserver.org/doku.php?id=virtual_network_interface&s[]=dummy#configure_green_and_red_role

So you have to enter the correct IP addresses in your case for green and red, attached to the correct interfaces.

I did it yet… control my posts… about 3 hours ago, the second with image attached. dummy is green but unusable and the physical one is red… both with an IP address

Where, in what menu did you make the screenshots?


configuration-> network

What is the output of ‘db networks show’ on the console pls?

db networks show
dummy0=ethernet
ipaddr=10.1.2.1
netmask=255.255.255.0
role=green
ens18=ethernet
FwInBandwidth=
FwOutBandwidth=
bootproto=none
gateway=192.168.19.1
ipaddr=192.168.19.20
netmask=255.255.255.0
role=red
ppp0=xdsl-disabled
AuthType=auto
FwInBandwidth=
FwOutBandwidth=
Password=
name=PPPoE
provider=xDSL provider
role=red
user=
red1=provider
interface=ens18
weight=1

Looks all fine, I assume 192.168.19.x network can reach the internet for it is a private adress. Can you tell a bit more about what exactly is not working?

cannot reach internet because one interface it’s not working

PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.

— 8.8.8.8 ping statistics —
13 packets transmitted, 0 received, 100% packet loss, time 12000ms
if one interface is not working nethserver only has a limited network functionality… or am I wrong?

But both IP addresses are private addresses, so they will never route to the internet…

no, you are wrong i’m sorry…
from menu diagnostic-> route
default via 192.168.19.1 dev ens18
10.1.2.0/24 dev dummy0 proto kernel scope link src 10.1.2.1
192.168.19.0/24 dev ens18 proto kernel scope link src 192.168.19.20
from another NS working correctly with similar configuration


where I setup a VLAN ( working ) from a dummy not working
that’s the problem I asking help to solve