Domain registration problem NS 6.8 / Win 10

NethServer Version: 6.8
Module: Windows Network

I am in process to replace some old laptops with new ones. All laptops to be replaced are running WIN 10 Pro are connected to the NS domain, working with no problem (shared folders, email…).
Yesterday I started the replacement process on one laptop and I disconnected it from the domain while offline (not connected to the company network).
The new laptop is running WIN 10 Pro and has been prepared to join back the domain : registry patch installed and assigned computer name identical to the one of the one replace (same user, new machine).
This morning, when back to the office, I tried to connect the new laptop to the domain, but I keep getting the following error message :

I guess the problem lies in the fact that I disconnected the old laptop while offline and now I try to join the domain again with the same computer name.

How can I solve this issue while keeping the same computer name?

Thank you

Massimo

Solved… nuked WIN10 and installed Linux.
Joking…
Reinstalled WIN10 and join domain before installing any other software.
Lesson learned

Massimo

1 Like

Spoke too fast…
After reinstalling the OS, WIN 10 accepted the request of joining the domain (welcome message), but after the reboot all domain resources were not available.
The OS reports that it is part of the domain… but in practice there is no domain!

Now I removed all DHCP reservations related to that PC/HOST NAME and I will try again after the temporary leases will expire.

I am clutching at straws, now…

Massimo

Hi @maxbet!

honestly I never met the problem.
Did you patch the registry as suggested in this page: Required Settings for Samba NT4 Domains?

Remember that joining a domain it’s all a matter of DNS: who is the DNS server of your clients?

And what about time and date? There must be not time offset between DC and clients.

2 Likes

Nicola,
registry was patched and DNS and gateway were passed correctly to the WIN10 client.
The issue was in the DHCP reservation : the new PC and the old one had the same host name but different MAC address. This created the problem.
Once I erased the IP reservation and waited for any temporary lease to expire, I could join the domain without any problem.

The error message was just a bit cryptic…

Regards.

3 Likes

i have a similar problem,
i want change an old pc win7 pro 64bit with a new win10 pro 64bit with all windows patch/update
the PDC work fine, but when i try to join the machine to the domain i have this mistake

all the old win10 machines (yet in a domain), without the update, work fine
I have try to create account machine with:
pdbedit -a -m “pcset034”$

and i see the account ok with:
pdbedit -Lv | grep machine

but when i try join the machine i recive the same message error
now i have delete the machine account:
pdbedit -x -m pcset034$
i have changed hostname and ip, but nothing

actual ip: 192.168.1.34
gw: 192.168.1.254
only dns1: 192.168.1.252 (PDC Nethserver 6.8)
Samba version 3.6.23-36.el6_8

i tried to see if the log can help me

log.smb
[2017/03/14 15:43:11, 0] smbd/server.c:1054(main)
smbd version 3.6.23-36.el6_8 started.
Copyright Andrew Tridgell and the Samba Team 1992-2011
[2017/03/14 15:43:12.967606, 0] rpc_server/srv_pipe.c:590(pipe_schannel_auth_bind)
pipe_schannel_auth_bind: Attempt to bind using schannel without successful serverauth2
[2017/03/14 15:43:13.091130, 0] rpc_server/netlogon/srv_netlog_nt.c:976(_netr_ServerAuthenticate3)
_netr_ServerAuthenticate3: netlogon_creds_server_check failed. Rejecting auth request from client SRV-ADHOC2 machine account SRV-ADHOC2$

But SRV-ADHOC2 work fine

I have try this:
https://support.microsoft.com/en-us/help/2696547/how-to-enable-and-disable-smbv1,-smbv2,-and-smbv3-in-windows-vista,-windows-server-2008,-windows-7,-windows-server-2008-r2,-windows-8,-and-windows-server-2012

but nothing, i have the same problem :frowning:
any idea?