DokuWiki reinstall not working


NethServer Version: 7.8.2003
Module: DokuWiki

Salut Stéphane

I installed your DokuWiki module, worked fine.

Then I made a few errors and thought I’d reinstall DokuWiki, removed it and reinstalled.
No change
Removed again (using yum), and saw that the folders and config (e-smith) were still there.
So I emoved both. (Folders /usr/share/dokuwiki /var/lib/dokuwiki and the e-smith Config Database entry)

Reinstalled. No, the folders are not reinstalled…

Tried yum clean all and various other options, but still the folders are not installed along with the module…

Any suggestions?


check nethserver-dokuwiki and dokuwiki are installed with all dependencies

after we need a more informations on what is broken


Thanks for the fast reply…

I think dokuwiki is not reinstalled, when nethserver-dokuwiki is reinstalled…
I’m verifying right now…


I should disconnect and for the sake of my mind, go to read a book…bad day :smiley:


Thanks for the pointer in the right direction.

Dokuwiki is not uninstalled, when nethserver-dokuwiki is uninstalled.
So it does not get reinstalled with nethserver-dokuwiki.

And I was way to strict with permissions, I had locked myself out (as admin of DokuWiki!).
So I had removed the folders - but not the dokuwiki via yum…

Now I removed both with yum, and reinstalled nethserver-dokuwiki, dokuwiki was correctly installed as dependency and now all is back working! Thanks! :slight_smile:

Yesterday was my personal “Not my day” day this week… :slight_smile:
Sometimes it’s surprising how much “sh*t happens” when it happens…

My 2 cents