Dnf saved me, (OK I say "à dieu" to apt)

Sorry, I am an “arch user like” that checks for updates every 5 minutes or so (I exaggerate).
So I got into the habit of: As soon as I finish installing a centOS or a Fedora machine, hop I activate EPEL and do a full upgrade … especially the kernel …

So when trying to install NS yesterday, I turned blue/purple, the nethserver-install script told me to get lost, because my server is not a centOS 7.7 or 7.8 something, I was pushed into the future with a centOS 7.9,

Ok, so I didn’t want to install the RC version of NS, and being on a VPS with an install of under a minute, I reinstalled , and kept good and wise this time.

NS got installed and I was happy.

Then when I tried to install a few modules (applications) , I bumped into a cul-de-sac, packages didn’t want to install because of mismatch in other system’s packages versions like mariadb-libs and other library things , mostly.

I lunched the install command line in a shell ans saw clearly that it was a dependency issue.

So I called yum, same difference … no go.

So I called dnf.

And there I got back to my natural color this time, mister dnf was politely asking me if it is OK to downgrade this and that package to get things done, I said: yes , be my guest !

The installations went superfine and everything is in order. Goal reached.

So here I would like to wisper a new feature/fonction/way-of-working:

Get the Nethserver use DNF instead of YUM, does yum do that with command line options ? I do not know, maybe with the downgrade option but yet it might be an extra step that dnf doesn’t need …

This way, instead of blocking an installation in the web-interface of NS, this interface by the use of DNF, can for example notify that packages will be downgraded if need, and do we want that or not, in both cases, we wont have to fireup a shell interface and do things manually, everything will stay at the web-interface as it is one of reasons of having a NS server…

Voila, have a nice evening (CET time)

1 Like

I always thought DNF wasn’t supported on CentOS?? (Not until CentOS8 anyways)
nice testimonial!

I was not completely wrong here: https://ostechnix.com/install-dnf-centos-7/
I don’t know if there are newer versions available… article is from 2018

Hmm, I don’t remember when, but a couple of years ago I think, I installed a fedora on my laptop for testing…
And somehow, dnf was in or I had to install it, curiosity ? , I am a cat, I will die this way I know it.
It could be to install a synaptic like program, that handles installations and upgrades/mirror management under gnome and natively, that relied on dnf and not yum …
And I read an article about dnf saying it’s a new generation kind of yum, and yum is getting retired sooner or later …
So since then, I usually install dnf on my centOS with yum … and I had never had to complain.
And one of the tricks to keep safe in a world with two gods: always keep them synchronized, if by habit/accident you updated or installed with yum, give a little run to “dnf update” too after that, even if it is superstition, It wont hurt :wink:

Via yum you can install dnf on CentOS7, therefore on NS7. If I’m not wrong this should honor also repositories configured in yum.

But honestly i won’t install and use dnf as package manager into a production server, only in test, both packages system can live on the same installation.

On my laptop I use Fedora and there DNF is supposed to be the default package manager. But because of NethServer, I am so used to yum that I most of the times use yum instead… habits…

Well, the same happens to me on Debian (typing yum instead of apt by mistake :man_facepalming:).

I cannot do a mistake, I use omyzsh with the dnf plugin : https://ohmyz.sh/

for example you do dnfu shortcut of sudo dnf update

same for


really handy


dnf is provided by redhat for a while now, and is official.
dnf is not another packaging system, it is a “rewrite” of yum, thus functions differently, but is still the same System, which is RPM, RedhatPackageManagement system,

For me now, it works with no issues, and it has been my Savior :slight_smile: