Disaster recovery problem

NethServer Version: 7.9.2009
Module: Backup

Hi Everyone,

I am trying to do a disaster recovery, to a new hardware.
Going through the documentation (using new server manager):

After install, i do login to web console, install all updates, with no errors.
Then on backup i am uploading the config file which i took from the HDD, where my original server was backing up to.
The config restore goes through with no error message, but the restore does not “finish” completely.

Backup is restored, DHCP i can see the reservations listed, Certificates, trusted networks all look fine, local samba AD is installed too, but here is the problem:
No users are visible.
Looking under applications, nothing is installed.

I did start the whole process again (install, update, config etc…), but got identical issue.

If i unoack the config file, i can see at least the application that should have been instaled.

Could anyone point me to the right direction, what i am missing?

If you used community/third party repos you may need to install them manually before starting the config restore.

1 Like

Thank you for the quick reply Markus.
To install the repos, that would be no problem, though the restore failed to install any application that are not from custom repo, like SOGo.
My main issue though is that the users are not populated, despite the restore went through without error.

Just tried creating 1 user, and looks like it goes through with no error, but as soon the gui is reloaded, it goes back again to showing no users.

If just 1 application has an issue (like missing repo) nothing is installed at all.

Maybe it helps to restart the NS DC?

systemctl restart nsdc

1 Like

I did not install the repos, so that explains why the packages are not installed.
I rebooted the server after the restore finished, but the users are still not showing.
I am trying to redo the whole process again, this time installing the AD component first, and see if the users are then populated.

1 Like

Reinstall #3:

-Before running the restore config, I installed 2 repos manually:
Mrmarkuz and stephdl
-Running the restore had identical outcome.
Tested to restart the nsdc service, but got an error:

systemctl restart nsdc
Failed to restart nsdc.service: Unit not found.

Lookig at Ad in gui:


Reinstall #4:

-Installed AD component manually (same ip as was originally
-Running the restore had identical outcome.
-This time running: systemctl restart nsdc → no error message.
-Installed 2 repos manually:
Mrmarkuz and stephdl
-Running restore config again, deselecting the reinstall package and reconfigure network option → ended in an error.
-Running restore config again,- selecting network reconfig and installing packages → finishes without error message, but issue is identical all along

Is nethserver-dc installed?

[root@server2 ~]# rpm -qa nethserver-dc

If it isn’t installed you may try to install manually:

yum install nethserver-dc

Maybe a DC upgrade helps:

signal-event nethserver-dc-upgrade

If the network changes, you may need to change the IP of the container, see nethserver-dc — NethServer 7 documentation

1 Like

Nethserver-dc was installed yes.
What i did was extract the confog archive and got the list of packages.
I installed manually all of them. The majority was already installed, the rest was installed successfully, except 2 packages:

yum install nethserver-virtualbox-5.2-phpvirtualbox
yum install nethserver-virtualbox-5.2-VirtualBox

At that stage the DC was not working properly, so i just did a reinstall again.
After that i did basically everything as per documentation, except that i modified the config archive, and in the package list, deleted the 2 lines refering to virtualbox (i don’t even know how it got there)
The restore failed, but upon checking in cockpit, everything seems to be fine:
All apps are installed, all users exists, Nextcloud works, SOGo etc… works.
Right now i am about to restore the data.
Not sure what that error that i got during the config restore was.
Is there any log that would tell me more?

1 Like

You could check /var/log/messages and maybe /var/log/yum.log.

1 Like

The data restore did finish initial, but, some items were missing:
SOGo → mails were there, but calendar and contacts were missing
Nextcloud → for 1 user, the data was missing. (kind of) When I logged in with that user, only the default files were visible. SSH to Nethserver and I can see the files actually be in the relevant folder for that user.
This is the user that I logged in to nextcloud, before the data restore, to confirm It is working. This might have screwed up something at that time.

Anyway, I redid the whole process again, this time not logging in with any user anywhere.
The data restore is still running.
I had a look at the yum log which did not show any errors.
In message log I can see the following errors (after the config restore):

core esmith::event[4767]: Action: /etc/e-smith/events/nethserver-collabora-update/S99nethserver-collabora-conf-php FAILED: 3 [0.011748]
core esmith::event[24800]: Action: /etc/e-smith/events/post-restore-config/S70system-adjust FAILED: 1 [83.648835]

Any way I can see what the 2 actions above were trying to do?

configures the virtual host and installs and configures the corresponding nextcloud app: nethserver-collabora/root/etc/e-smith/events/actions/nethserver-collabora-conf at master · NethServer/nethserver-collabora · GitHub

system-adjust: nethserver-base/root/etc/e-smith/events/actions/system-adjust at master · NethServer/nethserver-base · GitHub

1 Like

Thank you for the reply Marc.
Do these have their own log, so i can see what caused them to fail?
From Github i can see their action, but it was not obvious to me where they do log.

I think it’s just /var/log/messages but don’t take my word for it.

Thank you all very much for the help.
Removing the failing packages from the package list and then run the restore as per documentation did the trick.

1 Like