Disable everyone@ mail account


(Jurica Korac) #1

I’m not sure if this is a bug or a feature…

I migrated users to nethserver. Amongst them I have a user “everyone” with mail address everyone@domain.1. Whenever someone wants to send e-mail to everyone@domain.1, every single account gets the e-mail. Is there a command “everyone” that triggers this?

I have tested this.
I have a user everyone@domain.1
On nethserver there is domain.1, domain.2, domain.3, etc.
When I send email titled “test mail” from me@domain.xy to everyone@domain.1, every single user from every single domain gets the email. So test mail would get user1@domain.1, user2@domain.1, user1@domain.2, etc. not only everyone@domain.1 to whom I’ve sent mail.

I haven’t find any solution to this, and only thing that this implies to is that everyone is a trigger command that sends message to every user created on that nethserver no matter is it under the same domain or not. I’m using Nethserver 6.8, and 7 but haven’t tried it yet on 7.


(Filippo Carletti) #2

This is a feature in NS 6.8, a special email address that can be used to send an email to everyone. It’s enabled only for emails sent from users of the same system (i.e. if I send an email to your everyone@domain1 I will get a nonexistent address error).

everyone is not present in NS7.

(Jurica Korac) #3

Thank you.

Is there a way to disable it?

(Davide Principi) #4

Yes, a custom template is required:

mkdir -p /etc/e-smith/templates-custom/etc/postfix/virtual/
touch /etc/e-smith/templates-custom/etc/postfix/virtual/10everyone
signal-event nethserver-mail-server-save

Check if “everyone@…” is now always rejected/bounces.

More info about custom templates here:


On ns7, a similar feature can be obtained by creating a shared mailbox.

(Jurica Korac) #5

Thank you @davidep

Is there a similar feature for “everybody” ? I have more than 780 users on that server and testing it would provoke… earthquake.