DHCP and dns suffix ... wrong name resolution

Hi all,
i have upgraded my fw 6.8 to new 7
i have configured dhcp for green and blue network.

but i have seroiusly problem with mail.

thi is the situation
from client windows prompt

ping nas -> reply nas.mydomain.it

internal host PERFECT

ping mail.mydomain.it

reply mail.mydomain.it.mydomain.it WRONG

ping google.it

reply google.it.mydomain.it

but surfing on google or webmail.mydomain.it is good (proxy?)
for all mail client this problem is big

i have try to blank domain, but not resolve

this is my pc config

only temporaly solution is delete from registry editor this

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
“DhcpDomain”=“mydomain.it”

this resolve the issue.

What’s wrong?

Thanks and happy Easter

1 Like

What happens if you run the ping command on the NethServer host?

Also I see the DNS servers in your DHCP server configuration are both internal and external

192.168.1.254,8.8.8.8

That is not consistent,

I suggest to clean up all the advanced fields in DHCP br0 configuration, especially the Domain field!

Hi Davide thanks for reply.
I try ping and nslookup from server and this is good

I have cleanup all advanced settings in dhcp server, the result is the same.
Double domain suffix and wrong resolution.

the problem may be that the FQDN of the server contains the name of the external domain?

Server: proxy.XXXXX.it
Address: 192.168.1.254

Risposta da un server non autorevole:
Nome: google.it.XXXXX.it
Address: 46.252.xxx.xxx

This explains why the proxy resolves names correctly and clients can browse the WWW…

To see the effect on the client, we have to wait until its DHCP lease expires. I guess Windows has a command that forces it to happen immediately (ipconfig?).

i have try from linux host, nslookup work well

in windows 10 host, i have reboot, ipconfig /renew and ipconfig /flushdns
in cmd / powershell / cygwin nslookup dosent work

but surfing work well

thanks anyway