Data backup runs at wrong time

backup
v7

(Dan) #1

NethServer Version: 7.4
Module: backup-data

I’m noting strange behavior on my Neth 7.4 VPS installation with respect to the backup-data settings. I have it set to run daily at 0100, but it appears to be running at 1900 instead:
image
The system is set to EST time zone (UTC-5:00), which doesn’t match the offset–the backup is running 6 hours early. The server is showing the correct time and time zone:
image
Not the end of the world, but doesn’t seem right. Where should I look to straighten this out?


(Giacomo Sanchietti) #2

Could you please paste the content of this file /etc/cron.d/backup-data ?

This is the relevant code:


(Dan) #3
[root@neth ~]# cat /etc/cron.d/backup-data 
# ================= DO NOT MODIFY THIS FILE =================
# 
# Manual changes will be lost when this file is regenerated.
#
# Please read the developer's guide, which is available
# at NethServer official site: https://www.nethserver.org
#
# 
0 1 * * * root /sbin/e-smith/backup-data
[root@neth ~]# 

(Giacomo Sanchietti) #4

The cron job is good, so probably there is a bug in the web interface.

Could you please check when the job is really executed inside /var/log/cron?
You also take a look at the content of /var/log/last-backup.log.


(Dan) #5
Jan 22 16:16:01 neth run-parts(/etc/cron.daily)[19398]: starting backup-config-cron
Jan 22 16:16:02 neth run-parts(/etc/cron.daily)[19406]: finished backup-config-cron
Jan 22 19:00:01 neth CROND[7421]: (root) CMD (/sbin/e-smith/backup-data)
Jan 23 03:38:01 neth run-parts(/etc/cron.daily)[9312]: starting backup-config-cron
Jan 23 03:38:02 neth run-parts(/etc/cron.daily)[9320]: finished backup-config-cron
Jan 23 19:00:01 neth CROND[14636]: (root) CMD (/sbin/e-smith/backup-data)
Jan 24 03:11:01 neth run-parts(/etc/cron.daily)[16085]: starting backup-config-cron
Jan 24 03:11:02 neth run-parts(/etc/cron.daily)[16093]: finished backup-config-cron
Jan 24 19:00:02 neth CROND[18750]: (root) CMD (/sbin/e-smith/backup-data)
Jan 25 03:30:02 neth run-parts(/etc/cron.daily)[20363]: starting backup-config-cron
Jan 25 03:30:02 neth run-parts(/etc/cron.daily)[20371]: finished backup-config-cron
[root@neth ~]# 
[root@neth ~]# cat /var/log/last-backup.log 
Reading globbing filelist /tmp/buwP1TNedQ
Local and Remote metadata are synchronized, no sync needed.
Last full backup date: Sun Jan 21 01:00:48 2018
--------------[ Backup Statistics ]--------------
StartTime 1516838429.16 (Wed Jan 24 19:00:29 2018)
EndTime 1516838431.33 (Wed Jan 24 19:00:31 2018)
ElapsedTime 2.17 (2.17 seconds)
SourceFiles 336
SourceFileSize 23336559 (22.3 MB)
NewFiles 21
NewFileSize 80304 (78.4 KB)
DeletedFiles 1
ChangedFiles 109
ChangedFileSize 15605019 (14.9 MB)
ChangedDeltaSize 0 (0 bytes)
DeltaEntries 131
RawDeltaSize 4598436 (4.39 MB)
TotalDestinationSizeChange 1258972 (1.20 MB)
Errors 0
-------------------------------------------------

[root@neth ~]# 


(Dan) #6

This server is a VPS at Contabo in Germany (UTC+1), and I’m not sure I’ve restarted the server since configuring Neth (and setting the time zone). I’ve done that now; I’ll see if it fixes things.


(Dan) #7

The restart fixed it–probably restarting cron would have accomplished the same thing.