Conflict Packet Dahdi EPEL

Hello,

I run yum update today and have a conflict with new dahdi-tools packet on EPEL repository

epel/x86_64/prestodelta | 1.7 kB 00:00:00
(1/2): dahdi-tools-2.11.1-16.el7.x86_64.rpm | 329 kB 00:00:00
(2/2): dahdi-tools-libs-2.11.1-16.el7.x86_64.rpm | 33 kB 00:00:00
Total 1.8 MB/s | 362 kB 00:00:00
Running transaction check
Running transaction test
Transaction check error:
file /usr/lib64/libtonezone.so.2.0.0 from install of dahdi-tools-libs-2.11.1-16.el7.x86_64 conflicts with file from package libtonezone-2.11.1-2.4.gc2fbe3d.ns7.x86_64

Check repository or help to solutions.

Thanks!

2 Likes

Indeed you caught a conflict with EPEL, do you have freepbx installed?
Could you please post the output of:

  • rpm -q --whatrequires libtonezone
  • rpm -q --whatrequires dahdi-tools
3 Likes

Hi there!
I have the same problem here.

[root@server ~]# rpm -q --whatrequires libtonezone
freepbx-14.0-8.ns7.noarch
[root@server ~]# rpm -q --whatrequires dahdi-tools
freepbx-14.0-8.ns7.noarch

Indeed you caught a conflict with EPEL, do you have freepbx installed?

Yes, I have FreePBX installed and running.

2 Likes

Thanks you for fast response

I see issue open! Thank you for help!

3 Likes

@ibinetwork could you try this package https://github.com/NethServer/freepbx/pull/4#issuecomment-631566449 ?

yum update http://packages.nethserver.org/nethserver/7.8.2003/autobuild/x86_64/Packages/freepbx-14.0-8.11.pr4.ga31c5c2.ns7.noarch.rpm
2 Likes

Bad news!!

[root@router ~]# yum update http://packages.nethserver.org/nethserver/7.8.2003/autobuild/x86_64/Packages/freepbx-14.0-8.11.pr4.ga31c5c2.ns7.noarch.rpm
Loaded plugins: changelog, fastestmirror, nethserver_events
freepbx-14.0-8.11.pr4.ga31c5c2.ns7.noarch.rpm | 26 MB 00:00:03
Examining /var/tmp/yum-root-W2L7am/freepbx-14.0-8.11.pr4.ga31c5c2.ns7.noarch.rpm: freepbx-14.0-8.11.pr4.ga31c5c2.ns7.noarch
Marking /var/tmp/yum-root-W2L7am/freepbx-14.0-8.11.pr4.ga31c5c2.ns7.noarch.rpm as an update to freepbx-14.0-8.ns7.noarch
Resolving Dependencies
–> Running transaction check
—> Package freepbx.noarch 0:14.0-8.ns7 will be updated
—> Package freepbx.noarch 0:14.0-8.11.pr4.ga31c5c2.ns7 will be obsoleting
–> Processing Dependency: dahdi-tools-libs >= 2.11.1-16 for package: freepbx-14.0-8.11.pr4.ga31c5c2.ns7.noarch
Loading mirror speeds from cached hostfile
ce-base: mirror-centos-jpa.hostdime.com.br
ce-extras: mirror-centos-jpa.hostdime.com.br
ce-sclo-rh: mirror-centos-jpa.hostdime.com.br
ce-sclo-sclo: mirror-centos-jpa.hostdime.com.br
ce-updates: mirror-centos-jpa.hostdime.com.br
epel: d2lzkl7pfhq30w.cloudfront.net
nethforge: ns-mirror1.ibi.net.br
nethserver-base: ns-mirror1.ibi.net.br
nethserver-updates: ns-mirror1.ibi.net.br
–> Package libtonezone.x86_64 0:2.11.1-2.4.gc2fbe3d.ns7 will be obsoleted
–> Running transaction check
—> Package dahdi-tools-libs.x86_64 0:2.11.1-16.el7 will be installed
–> Finished Dependency Resolution
Dependencies Resolved
===================================================================================================================================================================================================
Package Arch Version Repository Size
===================================================================================================================================================================================================
Installing:
freepbx noarch 14.0-8.11.pr4.ga31c5c2.ns7 /freepbx-14.0-8.11.pr4.ga31c5c2.ns7.noarch 75 M
replacing libtonezone.x86_64 2.11.1-2.4.gc2fbe3d.ns7
Installing for dependencies:
dahdi-tools-libs x86_64 2.11.1-16.el7 epel 33 k
Transaction Summary
===================================================================================================================================================================================================
Install 1 Package (+1 Dependent package)
Total size: 75 M
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test
Transaction check error:
file /etc/modprobe.d/dahdi-blacklist.conf from install of freepbx-14.0-8.11.pr4.ga31c5c2.ns7.noarch conflicts with file from package dahdi-tools-2.11.1-2.ns7.x86_64
Error Summary-------------

1 Like

Installation worked on a test VM.

yum install nethserver-freepbx http://packages.nethserver.org/nethserver/7.8.2003/autobuild/x86_64/Packages/freepbx-14.0-8.11.pr4.ga31c5c2.ns7.noarch.rpm

Same error here (in a Enterprise installation)

You probably didn’t have epel repository enabled.

Yes, but it doesn’t affect automatic update. The problem on Enterprise/Subscription should pop out only if you force the update after cleaning the metadata.

The package is now in testing and should fix the problem (I’ve already tested it in a couple of machine).

@ibinetwork @PCXLan.es could you please try it? The test command (only on NS 7.8) is:

yum --enablerepo=nethserver-testing update freepbx
3 Likes
yum --enablerepo=nethserver-testing update freepbx

Its ok, update sucessfully! Thanks

Thank you to you for reporting and testing!

The package has been released and will land soon to all mirorrs.
We are going to release also the fix for 7.7 to not block those who are not willing to update to 7.8.

4 Likes