Configuration Backup - Shared Mailboxes missing

I did a planned disaster recovery this weekend and was impressed that this was really well working!
But as usually with complex software there are some bugs:
The configuration backup does not include any information about shared mailboxes, therefore restoration is not possible.

Workaround is easy:

  1. restore configuration from backup
  2. manually add shared mailboxes as needed
  3. restore data
    Shared mailboxes will now include old data

I can confirm this.

On NS7.4 I created a shared mailbox, made a config backup, deleted the mailbox and restored the config. No shared mailbox.

1 Like

I think this is a bug, do you agree @davidep?

1 Like

I agree it is a bug because (like Samba shared folders) shared mailboxes definition must be included into the configuration backup.

It is now included in data backup as the contents of the whole /var/lib/nethserver/vmail/vmail/ directory. We should cherry-pick some dovecot-specific files to cut out the mailboxes definition and permissions.

Edit: bug link

The package is ready for testing /cc @asl @quality_team

I tested it on a fresh installed and updated NS7.4 VM and Shared mailboxes are backuped and restored now via config backup.

But owner groups can not be added anymore. Adding some owner groups, submit, edit, no owner groups.

I tried to downgrade but no success, just can’t add owner groups anymore, also tried another browser but no luck.


Great catch Markus, I’ll fix it today

1 Like

Could you please assign the issue to you? So everybody knows that it’s up to you.

Sorry, I am new to GitHub and I don’t want to mess things up. It’s not exactly the same issue (backup config/owner groups) and I think I can’t assign it to me because I don’t have rights (no checkbox). Should I just do a comment?

1 Like

You’re right, if it’s not the same issue we have to keep them separated

A new package is available from testing repository

1 Like

Thanks for providing the testing update. I tested it now and in a deleted and restored shared mailbox the owner groups are not editable anymore.

Steps to reproduce:

  • installed nethserver-mail-server from testing
  • created test users, groups and shared mailboxes (testuser1, test1, testmb1 etc)
  • backup config
  • delete some shared mailboxes
  • restore config
  • editing owner groups in deleted and restored shared mailboxes not possible. After submit nothing changes.

Editing works until restoring the config. If a shared mailbox is not deleted before restoring it works normally.

A shared mailbox with this behaviour is also not deletable:


Thank you again. I’ve some troubles with non-recursive tar behavior :blush:

Please test it again. I hope it works now!

Edit and delete after restore works as expected! :+1: Thank you!


Do you want to update the GH issue?

  • add the “verified” label
  • remove the “testing” label
  • remove the assignment
  • optionally a comment about the QA phase

Do you have enough rights to do it?


thanks for testing and solving this issue to all!




Haha I tried it from mobile phone and there was no assignees or labels box. Now I know how it works. :blush: