Computers not passed when manual proxy is used

NethServer Version: NethServer release 7.5.1804 (final)
Module: Proxy
When I set the proxy server to use manual instead of transparent with HTTP and HTTPS blocking enabled, the computers on my bypass proxy list are not passed, they get blocked. I use the pass for servers that need to use various ports for services they are running. Can y’all help please? Thanks.

Did you set any (manual) proxy settings on those computers? I am no expert on proxy, but it might be necessary to configure the proxy on the computer even when there is a proxy override for that computer.
@giacomo @filippo_carletti @mrmarkuz

Hi. Yes, they are all set, using GPO.

The bypass list works at firewall level, so it makes sense only if the proxy is set to transparent.
If you force a single computer to use the proxy, the computer obeys and doesn’t bypass it :slight_smile:

1 Like

But that means that the entire proxy section is wrong. What good is a host bypass list if it does not work in manual mode, only transparent or transparent with SSL? Is it broken?

No it’s not, but as you’re pointing out the UI is not clear enough.

Just to recap:

  • Domains without proxy: can work for transparent/manual/authenticated proxy
  • Hosts without proxy: can work only with transparent proxy
  • Sites without proxy: can work for transparent/manual/authenticated proxy

Hi. So you are tell me that I cannot expect hosts without proxy to work with anything but transparent proxy? OK, but disappointing, I really wanted my hosts to have manual setting only. Thanks.