Communication with AD nethserver while working from home using vpn

NethServer Version: 7.9.2009
I installed the server and joined the notebooks to the domain locally at the company, however from home, the domain controller does not work, even though I ping it from my network at home, the controller does not work, if I change a password on the server, it does not replicate for those who use vpn.
server network:
domain ip: / ad ip:
VPN network:

Note: I can ping IP via the VPN, but the controller doesn’t see it, I don’t know what else to do.

Hi @Igor_Paiva

You might need to set “Trusted Networks” when using NS7…
Add in any VPN network, but also your Home LAN network.

Hope this helps.

My 2 cents

I’ve already entered all the networks in the “trusted networks” tab, but I still can’t do it…

What IP are you using at home?


The Client use Windows? If the answer is yes, i think that the Windows firewall is set in such a way that it only allows access from local IP addresses by default, i.e. from the local LAN. If you access with IP addresses from external IP networks, e.g. the VPN, it blocks this traffic.



home router network:
dhcp vpn network:
AD local network:

Yess, the tests are being done on Windows, I disabled the firewalls for testing, it didn’t work either:

[root@ad ~]# traceroute -d
traceroute to (, 30 hops max, 60 byte packets
1 gateway ( 0.472 ms 0.355 ms 0.336 ms
two * * *
3 * * *
4 * * *
5 * * *
6 * * *
7 *^C
[root@ad ~]#
traceroute stops at the internal network gateway, I’ve already tried creating rules in Mikrotik to release it, the rule passes data, but it still doesn’t work