Collaborative Document Editing?

Yes, in the same subnet. I used Win10 and Debian9.

From the Debian machine, what happens if you run openssl s_client -connect neth_ip:8082?

Used my Proxmox Server for the command:

root@pve02:~# openssl s_client -connect 192.168.xxx.xxx:8082

CONNECTED(00000003)
depth=0 CN = NethServer, O = Example Org, ST = SomeState, OU = Main, emailAddress = root@localhost.localdomain, C = --, L = Hometown
verify error:num=18:self signed certificate
verify return:1
depth=0 CN = NethServer, O = Example Org, ST = SomeState, OU = Main, emailAddress = root@localhost.localdomain, C = --, L = Hometown
verify return:1

Certificate chain
0 s:/CN=NethServer/O=Example Org/ST=SomeState/OU=Main/emailAddress=root@localhost.localdomain/C=–/L=Hometown
i:/CN=NethServer/O=Example Org/ST=SomeState/OU=Main/emailAddress=root@localhost.localdomain/C=–/L=Hometown

Server certificate
-----BEGIN CERTIFICATE-----

-----END CERTIFICATE-----
subject=/CN=NethServer/O=Example Org/ST=SomeState/OU=Main/emailAddress=root@localhost.localdomain/C=–/L=Hometown
issuer=/CN=NethServer/O=Example Org/ST=SomeState/OU=Main/emailAddress=root@localhost.localdomain/C=–/L=Hometown

No client certificate CA names sent
Peer signing digest: SHA512
Server Temp Key: ECDH, P-256, 256 bits

SSL handshake has read 1724 bytes and written 326 bytes
Verification error: self signed certificate

New, TLSv1.0, Cipher is ECDHE-RSA-AES128-SHA
Server public key is 2048 bit
Secure Renegotiation IS supported
Compression: NONE
Expansion: NONE
No ALPN negotiated
SSL-Session:
Protocol : TLSv1.2
Cipher : ECDHE-RSA-AES128-SHA
Session-ID: …
Session-ID-ctx:
Master-Key: …
PSK identity: None
PSK identity hint: None
SRP username: None
TLS session ticket lifetime hint: 300 (seconds)
TLS session ticket:
0000 - …
0010 - …
0020 - …
0030 - …
0040 - …
0050 - …
0060 - …
0070 - …
0080 - …
0090 - …
00a0 - …

Start Time: 1514118546
Timeout   : 7200 (sec)
Verify return code: 18 (self signed certificate)
Extended master secret: no

I had some download size error today, it worked yesterday. You are right, the repo should be used. Maybe it was because of installing repo and onlyoffice in one line missing repo key install that way…

This worked for me, yesterday:

yum -y install https://downloads.sourceforge.net/project/mscorefonts2/rpms/msttcore-fonts-installer-2.6-1.noarch.rpm
yum -y install http://download.onlyoffice.com/repo/centos/main/noarch/onlyoffice-repo.noarch.rpm
yum -y install onlyoffice-documentserver

Thanks, I think it was because I tried to install repo and package in one line

Oh my God, I just had to point my client-browser to https://neth_fqdn:8082 and accept the rule…

It works now… Thank you all !

2 Likes

3 Likes

Wow a lot of work so far! Keep up up guys and keep us posted

After this, I’d suggest adding to check that the document server is running and accessible–you should be able to reach it at https://neth_fqdn_or_ip:8082. And really, especially if you’re using trusted certs (like those from Let’s Encrypt), it really should be the FQDN. Any issues here (like certificate errors) will be harder to troubleshoot through Nextcloud, as we’ve just seen.

Edit: When you browse there, you should see this:

2 Likes

Fully agree, added your points.

I solved my repo download problem with

  • yum clean all
  • rm -rf /var/cache/yum

so I change it to download via repo again.

@mrmarkuz, followed your instructions for another test installation, and it’s working (again) without issues.

Another question is whether OnlyOffice supports legacy MS Office file types, or just the OOXML varieties–there’s still a lot of .doc files out there. The OnlyOffice app in Nextcloud, at least, only seems to deal with the OOXML types.

Thanks for testing.

Maybe we can convert the old doc files somehow (libreoffice). Don’t know if Collabora can handle legacy office files.

Should we write a HowTo or do we still need more tests ?

Basic installation seems to work. I think we are ready for an onlyoffice howto!

1 Like

OK, I suggest we discuss it tomorrow. Sleep well… :sleeping:

I propose to just link this post to a new howto topic.
Good night!

I tried it out now and it works even more splendidly than it was for half of a year ago! The very thing is, why not to add here pdf editing as well until onlyoffice itself doesn’t have this feature. For now, I use this tool alongside https://ds11.pdffiller.com and something like this exactly would be nice to see in oo but as a free feature, not a paid one

1 Like

Though PDF was not meant to be edited (IIRC), interesting idea. Indeed the desktop version of LibreOffice can “edit” PDFs, don’t know if this feature is available for Collabora Online. Nextcloud has some OCR plugin.