Collabora - The requested URL /browser/dist/admin/admin.html was not found on this server

NethServer Version: 7.9.2009 (final)
Module: Collabora and Nextcloud-Office

I’ve followed the steps in this collabora howto.

I’ve gone through this community post and this post

I’ve also configured my coolwsd.conf script to replace all instances of with I’ve set my admin username and password for collabora in the command line.

I’ve entered DNS CNAME records for collabora and nextcloud-office.

I’ve updated my Letsencrypt certificate to include and

I’ve opened TCP/UDP port 9980 in the shorewall firewall configuration.

I’ve restarted all associated services. I’ve even restarted my server.

I have not been able to access the admin page in any browser. I get ‘requested url not found’.

Additionally, when I try to save in the ‘Use your own server’ field in the Nextcloud Office configuration (logged in as the Nextcloud admin in a browser), it spits back ‘could not establish connection to the Collabora online server.

I’m at a loss at this point. Any suggestions on where to go from here? Thanks.

Please share your config, maybe there’s an error:

config show coolwsd

Maybe it helps to reconfigure Collabora:

signal-event nethserver-collabora-update

Did you update Collabora? Which version do you use?

rpm -q coolwsd

Why? This usually isn’t necessary and may break it. Please remove the changes. The Collabora admin console should work out of the box.
Collabora uses a reverse proxy to in /etc/httpd/conf.d/zz_collabora.conf so the admin console is reachable at

No port needs to be opened for Collabora.

That shoudn’t be needed, it’s already preconfigured.



I changed the config file back to /etc/httpd/conf/coolwsd.conf below:

# Apache2 reverse proxy configuration for Collabora Online
# Internet <-- SSL --> Reverse Proxy <-- No SSL --> coolwsd
# Make sure that you enable the following Apache2 modules: proxy, proxy_wstunnel, and proxy_http.
# Create a virtual host for Collabora Online and include this configuration file.

  Options -Indexes

  # Encoded slashes need to be allowed
  AllowEncodedSlashes NoDecode

  # keep the host
  ProxyPreserveHost On

  # static html, js, images, etc. served from coolwsd
  # browser is the client part of Collabora Online
  ProxyPass           /browser retry=0
  ProxyPassReverse    /browser

  # WOPI discovery URL
  ProxyPass           /hosting/discovery retry=0
  ProxyPassReverse    /hosting/discovery

  # Capabilities
  ProxyPass           /hosting/capabilities retry=0
  ProxyPassReverse    /hosting/capabilities

  # Main websocket
  ProxyPassMatch "/cool/(.*)/ws$" ws://$1/ws nocanon

  # Admin Console websocket
  ProxyPass   /cool/adminws ws://

  # Download as, Fullscreen presentation and Image upload operations
  ProxyPass           /cool
  ProxyPassReverse    /cool
  # Compatibility with integrations that use the /lool/convert-to endpoint
  ProxyPass           /lool
  ProxyPassReverse    /lool

I've already done `signal-event nethserver-collabora-update`.

Version = coolwsd-

You don’t need to create /etc/httpd/conf/coolwsd.conf because there’s already /etc/httpd/conf.d/zz_collabora.conf.
Just follow the documentation, there’s no need for additional configuration.

You didn’t define the VirtualHost but it’s required as explained in the docs.

config setprop coolwsd VirtualHost
signal-event nethserver-collabora-update

You defined AllowWopiHost but it isn’t needed if Nextcloud and Collabora are running on the same server.

To remove it:

config setprop coolwsd AllowWopiHost ''
signal-event nethserver-collabora-update

Thank you for the help, Markus. I didn’t create the coolwsd.conf file.It was put there when I installed collabora. I’ve renamed it to conf2 so it’s out of the picture. The zz_collabora.conf file is present also. I did all the steps you told me to and still nothing. However, now when I try to access the admin page in a browser, I get server not found rather than url not found. I can ping successfully. Here’s what config show coolwsd shows now:


UPDATE: I rebooted my nethserver and now I can access the coolwsd admin site. However, when I try to open a Word doc in Nextcloud, I get ‘Document loading failed. Failed to load Nextcloud Office. Please try again later.’

UPDATE: Followed your input on this post and did the richdocuments update, then signal-event nethserver-collabora-update and now I can open Office documents! Excellent! Thanks for all of your input, Markus!