Collabora - Help me understand how to replace OnlyOffice in NethServer Nextcloud

NethServer Version: 7.9.2009
Module: Nextcloud 27.0.1

Hello Team,

@support_team , @mrmarkuz

My Nethserver and Nextcloud is fully up to date.
I use a wildcard Certificate on my Nethserver as well as HAProxy to allow for access to my Nextcloud and my Webtop applications running on my Nethserver.

I’ve been using OnlyOffice on my Nextcloud for many years. But a recent update to my Nextcloud has broken my OnlyOffice and I can’t edit within the browser now. When I select a Word or Excel document my Nextcloud downloads it and does not show it in my browser for editing.

I’ve heard of Collabora and I see that there is a page on Nethserver Docs:

  1. I’m still unsure what steps I need to take to replace OnlyOffice with Collabora using my Nextcloud and Nethserver.
  2. What Virtual Host configuration do I need to do with regard to my Cert I’ve installed on my Nethserver?
  3. What Apps do I need to install/enable on my Nextcloud in order to get Collabora to open documents in my Nextcloud browser and not download? And do I need to ensure my OnlyOffice Apps are removed from my Nextgcloud?

Any advie or steps you can provide me would be greatly appreciated.


Why not simply remove Onlyoffice completely and then reinstall it? Isn’t that an option?

supervisorctl stop ds:
su - postgres -c “psql -c ‘drop database onlyoffice;’”
su - postgres -c “psql -c ‘drop role onlyoffice;’”
yum -y remove onlyoffice-documentserver nethserver-onlyoffice
rm -rf /etc/onlyoffice
rm -rf /etc/yum.repos.d/onlyoffice*
rm -rf /var/lib/nethserver/secrets/onlyoffice*
rm -rf /var/lib/onlyoffice
config delete fw_onlyoffice

And then reinstall according to the instructions from @mrmarkuz.




Hello Uwe @transocean ,

Really appreciate your input. Can you link me to the instructions provided by @mrmarkuz on how to re-install OnlyOffice?

Is this a command to issue on the terminal? I get an error thatbash: supervisorctl: command not found when I issue this command: supervisorctl stop ds:

I then tried to move forward with the next command but I was then asked for my onlyoffice password. I didn’t set a password for onlyoffice so I’m unsure what to input for this password?

Thank you.

Hi @greavette

yes, the commands are for the terminal (putty or others). I am able to uninstall my Onlyoffice instance with it.

And here is the documentation from @mrmarkuz for a fresh installation:




Then I’m a little more confused now.

I’m assuming using the commands you gave me won’t work since I didn’t use the documented steps you provided to me in the link.

I’ve always just added the Only Office and Document Server app to my Nethserver-Nextcloud. But looking at these instructions by @mrmarkuz it appears that installing OnlyOffice needs more attention and must be done in a certain way.

I will remove from my Nextcloud the OnlyOffice apps and run through the steps in the link you provided. Maybe this will allow my OnlyOffice to finally work! :slight_smile:

Thank you!

1 Like

Good luck…

Hello @transocean or @mrmarkuz ,

Are these steps to install OnlyOffice on Nethserver/Nextcloud current? It looks to me like this was updated in 2018.

I trued running through the quick install steps:

yum -y install
yum -y install Download msttcore-fonts-installer-2.6-1.noarch.rpm (mscorefonts2)
yum -y install
yum -y install nethserver-onlyoffice --enablerepo=mrmarkuz

I then checked my document server to see if it’s running and it’s not. I get an error.
I tried dropping the database and recreating the database but again no docuument server is running on port 8082.
I pressed the Save button in the Admin settings but no message is shown.

Anything else I can do to get OnlyOffice working?

Thank you.

You may try another

signal-event nethserver-onlyoffice-update

and if it doesn’t work a reboot as the service changed.