Cockpit terminal problem


#1

i have some problem with latest release of nethserver-cockpit (nethserver-cockpit-0.4.1-1.ns7.noarch)
selecting terminal or subscription i get the default landing page
on the logs:

Mar 6 17:46:51 ns76f3 cockpit-bridge: No entry for terminal type “unknown”;
Mar 6 17:46:51 ns76f3 cockpit-bridge: using dumb terminal settings.

does anyone have the same problem? and if it’s working, can you tell me which version of nethserver-cockpit are you using?
tnx


Terminal in Servermanager Cockpit is not working anymore
(Davide Principi) #2

I think it’s a permissions issue. I guess you logged in as non-root…

(The #development/testing subcategory should not be used anymore)


#3

root is the only user on the 2 vm i used for testing, the other is a small firewall with some user, but i logged in cockpit as root
tomorrow i’ll try on some other vm…

:+1: sorry i forgot it :sweat_smile:


(Ralf Jeckel) #4

I’ve the same problem. Loged in with root. It’s a VM on proxmox.
Installed version: nethserver-cockpit-0.4.1-1


(Stéphane de Labrusse) #5

Need to check… @giacomo we removed some entries from system-route.json, IIRC terminal, subscription, software-center and applications could be impacted?


(Giacomo Sanchietti) #6

@stephdl what files should be reset?


(Stéphane de Labrusse) #7

From memory

/etc/nethserver/cockpit/authorization/system-route.json

I think we have a dedicated commit for this


(Amort Gottfried) #8

and that means?


(Stéphane de Labrusse) #9

ok confirmed, I will commit, for terminal we test if the user (even root) gets the permission to use it

so in /etc/nethserver/cockpit/authorization/system-routes.json

add "terminal"


(Amort Gottfried) #10

Thank you very much!! Worked

Thank you very much!!


Terminal in Servermanager Cockpit is not working anymore
#11

is the same for “subscription” ?
tnx


(Stéphane de Labrusse) #12

my bad you are right…go to GH


(Giacomo Sanchietti) #13

My bad: I cut too much with my commits :smiley:

If you want to test it, you use this command:

yum install http://packages.nethserver.org/nethserver/7.6.1810/autobuild/x86_64/Packages/nethserver-cockpit-0.4.1-1.4.pr76.g5bfa593.ns7.noarch.rpm http://packages.nethserver.org/nethserver/7.6.1810/autobuild/x86_64/Packages/nethserver-cockpit-lib-0.4.1-1.4.pr76.g5bfa593.ns7.noarch.rpm

After confirmation, I will merge and release!

Thank you @stephdl


(Giacomo Sanchietti) #14

I can reproduce the error and I confirm the fix is working!

@stephdl is time to go back to holidays! :wink:


(Stéphane de Labrusse) #15

Yep, at barcelona currently


(Ralf Jeckel) #16

Confirm that fix works.
With user ‘root’ terminal and subscription are working.

With user ‘admin’ terminal doesn’t work:

Is this standard behaviour?

EDIT: Also Application doesn’t show anything with user ‘admin’.


With user ‘root’ it shows installed applications.


(Stéphane de Labrusse) #17

For the terminal and admin, you must add the shell access to the admin user, please confirm it

For the application, we should change something, all applications of cockpit are delegated but not the nethgui application. Try to install nethserver-mattermost and try it with the admin user, it must work


(Ralf Jeckel) #18

Confirm that cockpit terminal works, when ssh is enabled for specific user.
In fact it’s obviously, that ssh has to be enabled for terminal. My “blondiness” :blush: