Cockpit: nethserver-sogo

Hi all

It is almost done, need to do

  • translation
  • validation


I admit I followed the nethgui panel…what do you want more in the panel, what do you want to change…

Now it is time to talk

8 Likes

:thinking: Some UI thoughts

  • The “advanced settings” should have the same styles of other similar forms (e.g. Virtual hosts) - progressive disclosure with arrow + link. The on/off switch is for something that can be enabled disabled, whilst here it’s just a matter of visually hiding advanced information
  • A Dashboard?
1 Like

Hi Stephane,

great work as always. Thank’s a lot.

One point would be fine if possible: reduce log noise by checking a box or so.
(http://docs.nethserver.org/en/v7/sogo.html#sogo-floods-var-log-messages)

1 Like

what could I put in the dashboard

agreed for the switch, lets go to the advanced menu

yum install http://packages.nethserver.org/nethserver/7.7.1908/nethforge-testing/x86_64/Packages/nethserver-sogo-1.7.9-1.16.g4c7f676.ns7.noarch.rpm

it installs nethserver-sogo with the cockpit panel, please breack it.

1 Like

The Issue to test

2 Likes

released as nethserver-sogo-1.8.0-1.ns7.noarch.rpm

2 Likes

I have updated the NethServer, now it is in Applications, thanks!

1 Like

Hi @stephdl , thanks for the enhancement!

May I suggest a further enhancement? It’s only possible to add SOGo to the “Home-Page”. I think it would be fine if it were possible to start the SOGo-Homepage directly from application section, like it was in old GUI.
What do you think about making the “SOGo” in application section a link to https://nethserver.domain.tld/SOGo ? (same as ntop, phpmyadmin or collect charts)

Isn’t the app name a link? (just asking, didn’t check)

No, it’s not.:
grafik

But that’s what I wanted to say. Please make the app name a link. :smile:

Yep, I see. Didn’t read carefully enough. It is a handy feature, indeed.

Well the design could block me, either the link (in the manifest json) is internal and you go to open the menu application, or the link is external and you open a webmail like roundcube, …so…the best solution is probably to put a link inside the menu of SOGo, but you have to open first the menu.

What do you think, other ideas ?

cc @edoardo_spadoni

We can treat the case of SOGo like Mattermost. The name of the app is a link to /SOGo and Settings button in the application list set the properties of the application.

4 Likes

topissime (wonderful)

4 Likes

please test it before to release

yum install http://packages.nethserver.org/nethserver/7.7.1908/nethforge-autobuild/x86_64/Packages/nethserver-sogo-1.8.0-1.2.pr42.g76196cd.ns7.noarch.rpm
3 Likes

Update working here. :+1:
In cockpit applications I can click on SOGo and get to SOGo login and settings button leads to SOGo settings and shortcut is working too.

In /var/log/messages I get the following when I go to cockpit sogo settings (could be ignored maybe):

Dec  9 19:43:47 server2 cockpit-bridge: Use of uninitialized value $host in concatenation (.) or string at /usr/libexec/nethserver/api/nethserver-sogo/read line 44.

EDIT:

In Firefox in cockpit sogo settings the browser tab looks like:

grafik

4 Likes

Thank for the undefined var, it is fixed, but I cannot reproduce below

could you set the language of cockpit to english, maybe some translations strings are missing

BTW I fixed my first bug with vs code…not really proud of it :’(

1 Like

cockpit and browser language is english, it’s the same with chrome:

image

Web server settings show:

image

1 Like

ok you run a testing version of nethserver-cockpit, new translation feature are coming :slight_smile:

I can reproduce with

[root@ns7loc14 ~]# rpm -qa | grep nethserver-cockpit
nethserver-cockpit-1.3.9-1.2.gb7ba64b.ns7.noarch
nethserver-cockpit-lib-1.3.9-1.2.gb7ba64b.ns7.noarch
1 Like