Cockpit/ Dashboard loads widgets forever + error at system-task/read

Got a very new nethserver server with nextcloud and samba to try out from our it company, the cockpit and dashboard seemed ok for the first day, now it loads the widgets like Hardware/CPU/DNS forever, see picture.

I could add a group and some users, got nextcloud to work with webDAV (Raidrive, native windows webDav could not access). So dar so good, but I like to compare the speed of webDav & samba file sharing, and cannot access the nextcloud settings (or any other) I just get the “i am loading” circling icon.

Tried restart the nethcloud (terminal worked), restarted PCs.
Webbrowser: Firefox 69.0.2 (64 bit, swedish)
Also tried internet explorer -> “you need a modern safe webbrowser instead”
Also tried edge -> hard to log in, only get black or white empty page in the end.

Certificate: using self signed, IT company set this up.
Access: local ip or local domain name resolved to local ip. Or public dns resolved to public ip.
User: Using same admin account as I got in the beginning.

Must be something really stupid on my part, since it worked just some days ago, can you help me find the problem?

NethServer Version: 7.6.1810
Module: your_module

When you see Error in the top right corner of the screen with a “Copy command” button, click it, go to Terminal and paste the command. It will output more details about the error. You can paste those details here if you can’t figure out the problem.

I can see that system-task/read has failed, but I can’t guess why.

For reference, here’s the output on my system:

[root@ns76-ent ~]# /usr/libexec/nethserver/api/system-task/read | jq
{
  "steps": -1,
  "event": null,
  "message": "no running tasks"
}
2 Likes

Thanks @ filippo_carletti I found the error. It boiled down to “parser error in sudoer.d file 30…”. Quite strange, maybe it had to do with naming of a group I made. I called it something like foo-bar, with a minus sign. I manually commented that line away in the file and could get the cockpit to work again.

What are the requirements for group and user names by the way? Seems like space is not ok, but exist in the given groups like “domain admins”.

Also I still cannot get nextcloud to access the samba files share access from windows (net use… ) I played around with the settings in nethserver/nextcloud. I ended up with being able to connect (net use …) without any password, but only got read access.

I have a feeling I have some problems with users and groups somehow. Also the admin user I got is not listen in the users, and where do I find the group “domain users” if I need to change anything?

Seedman

I think the nextcloud admin guide is quite clear on this:
https://docs.nextcloud.com/server/16/admin_manual/configuration_files/external_storage/smb.html

This is due to the new delegation implementation.
Sudo is a little picky on the syntax so a valid group name for the account provider could be invalid for sudo configuration.
Could you please post the error here?

I cannot find the error back, looked in /var/log/messages + gzipped. Only find the “created group” and “deleted group” etc.
The group name was thermoseed-users

Sorry robb, I don’t find info on how to set up the normal file share for windows pcs on the link you gave.
I am just aiming at accessing a test folder on the nethserver/nextcloud to test speed. I can access from a windows 10 pc with “net use z: \ip to server \share”, but only if I set permissions to All=read/write. So it has to do with my lack of knowledge in getting the users/groups to work in nethserver & nextcloud I think.

I had the impression you wanted to access an SMB/CIFS share through nextcloud (by mounting the share in nextcloud) That is what the link is for.

Thank you, we will try to reproduce

I got help from our it company, that solved it. It turns out I have to use a username@domain.name instead of just username for the samba share.
Can you tell me more about this? Can I use username@ip-adress, username@local.domain, user@public.domain?

For nextcloud/webdav I just used username, so there is a difference between the two access methods.

Never heard of this above, I could be wrong but for me these two ways are compatible

username
username@domain.com

thank, I can reproduce the bug, fix is coming.

For the record, all permissions comes from sudoers file, we use Cmnd_Alias and it seems it doesn’t like the - in name

the fix is quick this time, the upgrade to 7.7 will fix this and many other cool feature in cockpit

stay in touch

2 Likes