Cluster leader not reachable

NethServer Version: NS8 Beta1 on Debian 11

I installed the cluster leader on 192.168.3.209.

The browser cannot connect to https://192.168.3.209/cluster-admin/

I had no such problem evaluating the Alpha.
Sincerely, Marko

Did the NS8 installation finish correctly? During testing, one time the installation was interrupted due to a not working download.

Is traefik listening on https port?

root@node1:~# ss -ltp | grep https
LISTEN 0      4096               *:https            *:*    users:(("traefik",pid=827,fd=9))
1 Like

I think so.

Writing manifest to image destination
Storing signatures
19d93e981c33f9f41bae92b525644f133cfdd431fbdb8cec171d43183fda455b
<7>extract-ui Package traefik · GitHub
Extracting container filesystem ui to /var/lib/nethserver/cluster/ui/apps/traefik1
ui/index.html
ebc2fc066f7e1013d31cd525a02760451dc08d427b03e58e68535b8aa2a6d6a1
{‘module_id’: ‘traefik1’, ‘image_name’: ‘traefik’, ‘image_url’: ‘Package traefik · GitHub’}
Setting default admin password:
True

NethServer 8 Core

Finish the cluster configuration by running one of the following procedures.

A. To join this node to an already existing cluster run:

My last action was to create the cluster leader, finished with the joining information for the admin user.

# ss -ltp | grep https

…no out put

1 Like

Did you do it on command line or in the web UI?
I think it wasn’t possible in the alpha version but now you can go to https://<ip>/cluster-admin immediately after NS8 installation to create the cluster.

It was.

The trailing slash is important: https://<ip>/cluster-admin/

1 Like

Here it worked without it, it’s appended automatically.

1 Like

Hmmm, perhaps that’s changed. When I first tried NS8, it wouldn’t work without it.

I created the cluster leader within the console.

I did and just forgot to post it here.

Addional I checked the web server…

systemctl status apache2

● apache2.service - The Apache HTTP Server
Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
Active: active (running) since Mon 2023-05-15 07:36:37 CEST; 8min ago
Docs: Apache HTTP Server Version 2.4 Documentation - Apache HTTP Server Version 2.4
Process: 418 ExecStart=/usr/sbin/apachectl start (code=exited, status=0/SUCCESS)
Main PID: 538 (apache2)
Tasks: 55 (limit: 9492)
Memory: 11.6M
CPU: 187ms
CGroup: /system.slice/apache2.service
├─538 /usr/sbin/apache2 -k start
├─539 /usr/sbin/apache2 -k start
└─540 /usr/sbin/apache2 -k start

cat /etc/apache2/mods-enabled/status.conf
# Allow server status reports generated by mod_status,
# with the URL of http://servername/server-status
# Uncomment and change the "192.0.2.0/24" to allow access from other hosts.

<Location /server-status>
	SetHandler server-status
	Require local
	#Require ip 192.0.2.0/24
</Location>

# Keep track of extended status information for each request
ExtendedStatus On

# Determine if mod_status displays the first 63 characters of a request or
# the last 63, assuming the request itself is greater than 63 chars.
# Default: Off
#SeeRequestTail On


<IfModule mod_proxy.c>
	# Show Proxy LoadBalancer status in mod_status
	ProxyStatus On
</IfModule>

#vim: syntax=apache ts=4 sw=4 sts=4 sr noet

ps -eo comm,etime,user | grep apache2

apache2 12:42 root
apache2 12:42 www-data
apache2 12:42 www-data

That seems very likely to be a problem; my installation of NS8 doesn’t have Apache installed at all. Where did it come from?

1 Like

Indeed.
Apache should not be installed because traefik must listen on port 80 and 443.

Ok! It’s more clear now.
I installed Webserver together with the basic Debian installation.
I will repeat the installation.

I do think this points to a shortcoming in the installer script, though, in that it’s not very good at detecting and either fixing, or aborting on, errors. Trying to run it on a system that has Apache running, for example (assuming it’s listening on the default ports), should result in an obvious hard failure. But it doesn’t; the installer script behaves as though the installation was successful.

That’s certainly your problem. Minimal install is all that’s needed.

3 Likes

Added a new card for the check.

1 Like

Reinstallation works fine.
Thank you.

2 Likes

Thank you for the new test Marko!