Cluster-admin connection error on Debian

Hey Guys, i installed the NS8 on a debian 11, from the install it seems to be good so far, but if i am trying to reach the ui i got an connection error. system is reachable by dns and ip, i can ping it and get an answer. any ideas? it is an proxmox container, fresh installed.

You’re not alone! Kubic repositories were updated yesterday and I got some troubles with Debian this week too.

Search for errors with journalctl and if you like share your thoughts here.

Maybe for a solution it’s better to wait a few days and try again.

I’m starting to think that Debian 12 will be better to start with.


thanks for the quick answer, will do so. if i find something interesting, i will give a shout !!!


I’m new to Netserver and i’m trying to install v8 on VMware
I’ve installed succesfully Debian 8 and installed Nethserver 8 according the instructions.
During installation and also afterwards i did not see any errors.

No i’m trying to access the UI but unsuccesfull.

400 Bad Request

Not Found

The requested URL was not found on this server.
Apache/2.4.54 (Debian) Server at Port 80

How can i access the UI ?

Check if the API server is running and reachable from localhost:

systemctl status api-server

API server is running and reachable.

I tried to check if HTTPS ia availabe and get this error

telnet localhost 443
Trying ::1...
telnet: Unable to connect to remote host: Connection refused

Could this be the problem ?

NethServer 8 Scratchpad

Finish the cluster configuration by running one of the following procedures.

A. To join this node to an already existing cluster run:

      join-cluster <cluster_url> <jwt_auth>

   For instance:

      join-cluster eyJhbGc...NiIsInR5c

B. To initialize this node as a cluster leader run:

      create-cluster <vpn_endpoint_address>:<vpn_endpoint_port> [vpn_cidr] [admin_password]

   For instance:

      create-cluster Nethesis,1234

Finally, access the administration UI at:

   User: admin
   Password: Nethesis,1234

Do i need to make a cluster or node or something like that ?

You need to initialize your node.

Can you give me a bit more support. I’m pretty new with Nethserver and Debian

I’ve tried this but it fails

create-cluster Nethesis,                                                                                 123
Traceback (most recent call last):
  File "/usr/local/sbin/create-cluster", line 45, in <module>
  File "/usr/local/agent/pyenv/lib/python3.9/site-packages/requests/", line 943, in raise_for_status raise HTTPError(http_error_msg, response=self)
requests.exceptions.HTTPError: 401 Client Error: Unauthorized for url:

It seems there are spaces between Nethesis, and 123 and 4 is missing so maybe you have to reenter the command correctly.

create-cluster Nethesis,1234

Maybe it’s a typo but Debian 11 is required for NS8.

1 Like

Thanks. That worked !
And i did

join-cluster --no-tlsverify eyJhbGciOiJIUzxxxxxxxxxxxxxxxxxxxxxxxxxxx

Only still no Cluster-admin access

Could it be the cluster is not configured correctly ?
The server has IP and i see in the create-cluster

Yes. I’m using Debian 11

join-cluster is only needed when you want to join another node to the cluster.
create-cluster should be enough.
If you created a snapshot I recommend to revert because maybe the join-cluster command breaks the installation.

I rechecked my NS8 installation and I used too. AFAIK it’s the internal VPN for the containers.


Thanks Markus, but still not working
i’m getting out of options

I retried it on my Proxmox VM and it just worked.
debian-11.2.0-amd64-netinst.iso was used to install a minimal system.
The system was updated and rebooted before starting the installation.
I enabled SSH root access to connect to the VM. If you connect via SSH as a normal user, don’t forget to use su - to get the full root environment.

After executing

curl | bash


create-cluster nethdeb.domain.local:55820 Nethesis,1234

I was able to browse to https://<IP>/cluster-admin and log in as admin.

Maybe try CentOS Stream 9 as alternative, see requirements.

1 Like

Well… i do not know why it is not working.
I’ve tried many installs and did it exactly how you discribed it
Everything works, like Domoticz or Plex, but Netherver is not accessable

Could it be that https is not accessable ?
When i go to the IP address is see the Apache page. Going to the HTTPS site it gives an errror


Do you use VMWare ESX for virtualization? Maybe it’s an issue at virtualization layer…
Do you use the VM in bridged mode? Other modes may cause problems.
Is the system time/date correct? This may cause issues for example with certificates.
Is it in the same network as the client that tries to connect? NethServer may block access to the UI from other networks.
Did you already try another browser/client? Maybe it’s not a server problem…

My debian install notes:

Graphical installer
English language
Location - Austria
Locale en_US.UTF-8
Keyboard - German
Hostname - debiantest
Domain name - domain.local
Root password
New user - markus
Partitioning - Guided - use entire disk
Partitioning scheme - All files in one partition
Scan extra media - No
Software selection - Only SSH server and standard system utilities are needed
Install Grub - select the right device

SSH into the debian machine and install NS8:

ssh markus@
su -
apt-get install -y curl
curl | bash
create-cluster debiantest.domain.local:55820 Nethesis,1234

Here’s the complete install procedure to compare:

1 Like