Clicked save to draft and lost mail!

Well subject says it all.
Could this be a bug nobody noticed?
Or a problem with my installation? (I don’t see how)

Note that when my wife pressed “back” by mistake (mouse shortcut), an email was in draft folder and we didn’t have to write everything again. It worked fine.

But a few minutes later, when I explicitly pressed “save to draft”, it took me to an empty Draft folder.
Reftesh, back, etc. didn’t save the day. Mail was lost (which was a bit tough because it was full of contract numbers we had to retype).

Any ideas?

EDIT: Some extra info.
The problem happened using MS Edge and my wife’s email account (not a webtop admin).
When I tried to replicate this using my own account (also webtop admin) and using Chrome.
Draft was saved fine.
I will try to replicate exactly the same situation.

EDIT #2: Well that was weird. When I opened Edge, logged in Webtop with my wife’s account, webtop informed me there are unsaved data (!)… and… it was the lost email!
Anyway, then I tried to replicate the original issue… made a test mail, clicked save draft… and it was saved.
Now it works, which is weird.
I could delete the post (as I probably resolved this before anybody’s reaction), but prefer to leave it here, in case this happens to anybody else and there is some info that could help devs.


Yep keep it sometimes bug needs time before to be found or reproduced… Btw throw away edge :slight_smile:

1 Like

I don’t use Edge (although the newest based on Chromium is supposedly good).
I only used it so I don’t log out, when my wife needed to read her mail from our mail server.

1 Like

You should be able to reproduce the problem so we can study it.
I use webtop daily since 2 years and it never happened. I send so maaany email everyday :slight_smile:

How much time passed since the writing draft and the “back” pressed?

couple of minutes
wife went next room to bring something so I clicked save draft, waiting for her
we had to rewrite the mail