Clear Yum Cache

NethServer Version: 7.2.1511 (rc2)
Module: Software Center

I have this problem
I have tried both pressing the button and cleaning in from cmd.

yum clean all

I can update fine from command.

yum update

No Problems here.

Any Ideas?

Can you elaborate what you did before the message appeared? Did you try to install modules that confilcted with eachother? (for instance trying to install openldap when Samba4 AD already is installed)

The only thing I did was removing shorewall.
it caused to much problems for me. But I don’t really need it since it is a lan server.

Shorewall is a default package. Maybe @giacomo or @davidep can explain the yum error. Personally I would leave shorewall be and if you absolutely don’t want to use it, configure it with all ports open.
But even on a LAN it is a good havit to have a firewall present. Even standard workstations have a built-in firewall.


well standard workstations do have.
but anyway. I’m having so much issues with having the shorewall on.

after x hours I have to restart my entire server to get Teamspeak working again.
Haven’t had any problems since I turned of Shorewall. I can’t have a server that closes up ever x hours :wink:

How did you remove shorewall? Why?

I’m not surprised if your system is not working properly!

Like I said, because it caused more pain than gain :wink:

yum remove shorewall

Well I can try adding it again and see if it works.

Try with

yum install @nethserver-iso

To get also other dependencies

1 Like

yeah that solved the error.
So thanks :slight_smile:

Lets just hope that the shorewall is more stable now.

Hi davidep,

I had to correct my network config first, but your solution worked for me also.


2 posts were split to a new topic: Useful commands

A post was split to a new topic: Could not resolve host:

Hi, I’m having the same issue with the yum cache; this comes about when I try to install applications from the Software Center from the very beginning; none have been installed by me yet. Repeated prompts to clear the yum cache and apparently zero effect. Am I missing something? And would the “yum install @nethserver-iso” fix it?

You can try to install @nethserver-iso, it will reinstall all missed base dependencies.

You should try also in a terminal

yum clean all
yum update

1 Like