Choosing mail recipient for stephdl updates

NethServer Version: 7.9.2009
Module: system mail

Hi all,
I have one server with installed stephdl reopository which sends system mails via smarthost. Mails are sent to root@MyDomain.local. Only stephdl update mails are sent to the following three users

  • root@MyDomain.local
  • administrator@MyDomain.local
  • admin@MyDomain.local

For admin I always get a message, that this user doesn’t exist.

My question is where to change this behaviour?

Thanks in advance


cc @stephdl

In /sbin/e-smith/check4StephdlUpdates you may edit

MAILADDR="root admin@$DOMAIN administrator@$DOMAIN"

but with the next update the file will be overwritten.

The repos of @danb35 and me are sending to admin too even if admin doesn’t exist.

The intention is to send update mails to all relevant users by default.

We could check if admin or administrator exists to supress the error or add a db prop to set the recipients…

Maybe we should just forward all update mails to root so one can set external mail addresses in System settings but this is not always wanted (no need for all cron mails) and it’s not default. :thinking:

1 Like

create the admin user :smiley:

1 Like

Of course I can create it, but if I set a user for email notifications at cockpit, why not use this user?
It’s easier to check one mailbox then three or four for the same reason, a system mail.

as ever we could enhance and change behavior :smiley:

1 Like

Thanks Stephane, I opened a feature request.

For your information I only send now to the root user. The root email in generally speaking are forwarded to an external email most of the time