Changed LAN address and bad things happened

network
openldap
webtop5

(bob) #1

Version 7.4 (Fully configured)

I changed the LAN IP address last night, and broke the system :sob:
but thanks to ZFS and snapshots, I recovered the system :grinning:

The system is running OpenLDAP with 5 users, webtop and normal gateway type systems. WebTop “died” and the system was very unresponsive.

I wish I’d seen this post before I started:

My guess is that I’d broken the LDAP server and that took WebTop down with it.

Should we be able to change the LAN IP address once the system is configured?

If not, please can a big label be added to the network tab saying “don’t change the LAN address”.

For those who are wondering, I’ve set up NethServer in a fully virtualised environment using 192.168.1.1 as it’s LAN address. The NethServer is to replace another CentOS server, which also has LAN address of 192.168.1.1. I changed the NethServer LAN IP to 192.168.1.150 so I could run both gateways on the same network and then transfer the IMAP data across using imapsync. Once I’d moved the IMAP data across I was planning to shutdown the old gateway and move the NethServer LAN IP back to 192.168.1.1.

Regards
Bob


(Giacomo Sanchietti) #2

Hi bob,

the linked thread talks about Samba 4, which is not your case.
Also, this operation can now be done using the UI even for the DC.

Of course! :slight_smile: Changing the green IP address of a machine is a common operation. From my experience, I can say that problems are usually network-related, like duplicate IPs in the LAN.

After changing the IP, make sure no other host as the same address using the arping command.
Check also /var/log/firewall.log and /var/log/messages to find martian packets.

Also make sure that the DNS is correctly configured since some services could use it to access the resources.


(bob) #3

@giacomo I think it was probably the DNS. I’ll go through the logs and see what I can find.

All I was trying to do was move the IMAP data from one server to the other. I can do that via the red interface since there is another firewall between that and the internet.

Thank goodness for ZFS snapshots!

Regards
Bob


(Michael Träumner) #4

If it is solved, could you mark the topic as solved please.


(bob) #5

Sorry, I was writing up my final comments, but forgot to send them.

I don’t know exactly what happened. I recovered the system from a snapshot backup and everything is OK.

I transferred the IMAP data via the red interface (should have done that all along!!).