Change wordpress options inactive

Neth server 7.6.18
Name : nethserver-wordpress
Arch : noarch
Version : 1.1.6
Release : 1.ns7.sdl
Size : 16 k
Repo : stephdl/7

Hi, I’ve noticed that shell commands for wordpress changes have no effect on the installed package. I tried a few but without having the desired result.
Here is:
[root @ neth7 ~] # config setprop wordpress status enabled
[root @ neth7 ~] # signal-event nethserver-wordpress-update
[root @ neth7 ~] # config setprop wordpress status disabled
[root @ neth7 ~] # signal-event nethserver-wordpress-update
Practically changing the state to private or public does not change the current configuration that remains proactive.
Am I wrong? I’ve always run these directives with previous versions which have always worked.

Could you paste what you find in log messages after you launch the two signal-event

Does the template of /etc/httpd/conf.d/zzz_wordpress.conf is expanded, does the apache service is reloaded

does the wordpress site is still active and workable ?

Hello and thanks for the reply.
I tried to verify how much you wrote to me and in my opinion despite this, if you enable or disable or change the status in private or public wordpress I don’t see any effect on the server. Actually, I tried to update the module some time ago, and it gave me these strange flaws. I solved it by restoring a snapshot of the virtualbox server. However, what interests me is just understanding why it doesn’t work, since I use wordpress only within the LAN and for testing. Maybe I’m wrong about the command syntax? Also h or tried rebooting apache. I attach the server logs.

[root@neth7 ~]# config show wordpress
[root@neth7 ~]#
Oct 21 08:52:22 neth7 /sbin/e-smith/db[2739]: /var/lib/nethserver/db/configuration: OLD wordpress=configuration|AutomaticUpdater|enabled|MaxExecutionTime|60|MemoryLimit|128M|PostMaxSize|32M|UploadMaxSize|50M|WebFilesMod|enabled|access|private|status|disabled
Oct 21 08:52:22 neth7 /sbin/e-smith/db[2739]: /var/lib/nethserver/db/configuration: NEW wordpress=configuration|AutomaticUpdater|enabled|MaxExecutionTime|60|MemoryLimit|128M|PostMaxSize|32M|UploadMaxSize|50M|WebFilesMod|enabled|access|private|status|enabled

Oct 21 08:52:55 neth7 esmith::event[2796]: Event: nethserver-wordpress-update
Oct 21 08:52:56 neth7 esmith::event[2796]: Action: /etc/e-smith/events/actions/generic_template_expand SUCCESS [0.166353]
Oct 21 08:52:56 neth7 esmith::event[2796]: Action: /etc/e-smith/events/actions/adjust-services SUCCESS [0.097416]
Oct 21 08:52:56 neth7 esmith::event[2796]: Event: nethserver-wordpress-update SUCCESS

Oct 21 08:54:01 neth7 /sbin/e-smith/db[2940]: /var/lib/nethserver/db/configuration: NEW wordpress=configuration|AutomaticUpdater|enabled|MaxExecutionTime|60|MemoryLimit|128M|PostMaxSize|32M|UploadMaxSize|50M|WebFilesMod|enabled|access|private|status|disabled
Oct 21 08:54:04 neth7 esmith::event[2945]: Event: nethserver-wordpress-update
Oct 21 08:54:04 neth7 esmith::event[2945]: Action: /etc/e-smith/events/actions/generic_template_expand SUCCESS [0.099058]
Oct 21 08:54:04 neth7 esmith::event[2945]: Action: /etc/e-smith/events/actions/adjust-services SUCCESS [0.089262]
Oct 21 08:54:04 neth7 esmith::event[2945]: Event: nethserver-wordpress-update SUCCESS

hum lets try to reinstall it

yum remove *wordpress* -y; yum install nethserver-wordpress -y --enablerepo=stephdl

sorry for the delay to answer, I am on holidays, and when my wife sees me on the laptop…I fear against my life

Hello and thank you, I understand the risk of life … hi
I’ve tried and everything works, but … nextcloud doesn’t start anymore!
I have investigated and I have seen that after the operation that you have made me perform, php 7.2 is under arrest and does not need to know to leave. I restored the virtualbox server snapshot … I am attaching screen shot.
Thanks as always .

ok…can we postpone until the next week, I will have more time…I think I put a mess :expressionless:

what were the flaws, please, could you describe them ?

Of course yes ! Thanks anyway for your interest.
The flaw is that after updating to the latest version of the module, on my server the wordpress signal event commands did not affect the change of configuration. After your answer or removing and reinstalling everything, the signal event for wordpress update worked as usual. I realized that after this operation the nextcloud module stopped starting. I investigated and noticed that php 72 did not start anymore. I restarted apache and the server, but nothing to do. In the end I restored the snapshot of virtualbox where it runs neth7 and I found myself in the original condition … However from the screenshot you can see the status of the services after the upgrade and before the upgrade. Thanks .

1 Like

in few hours, please update from my repo

yum update --enablerepo=stephdl

the nethserver-wordpress-update event should be active

1 Like

Hi Stéphane, I updated as you indicated. At the moment everything works correctly, nextcloud is running and the signal-events for wordpress work. I noticed that as soon as the module was updated, wordpress was in a deactivated state. It was sufficient to issue an “enabled” signal-event to restart it. At the moment everything is ok. I ask you why in the previous version, after the nextcloud update did not start … I assume the shutdown of php 72 … You were as fast as lightning !! Thanks

1 Like