Change VPN back to UDP via CLI [solved]

NethServer Version: 7 final
Module: vpn


I have trouble connecting back to my server. I accidentally changed the protocol from UDP to TCP for my road warrier. I don’t have access any more to my admin interface :frowning:

Unfortunately I cannot find out, how to change this back using the command line and e.g. “db setprop”.

Can anybody help?

“db vpn show” just gives me


The following is empty (the same with “vpn” instead of “openvpn”)


also empty:


THX Axel

If you’re using openvpn roadwarrior then the configuration is here:

config show openvpn@host-to-net

To clear the TCPPort and set the UDPPort to 1194:

config setprop openvpn@host-to-net TCPPort '' UDPPort 1194

To apply the config:

signal-event nethserver-openvpn-update

1 Like

Thanks a lot.

Should have read more carefully nethserver-openvpn — NethServer 7 documentation

But unfortunately this does not work - changed something else !? Probably I think I have to re-enable SSH on red interface (really, this command line template system is not easy stuff).

Will try …

1 Like

The problem was: I had to save and update:

If anyone is interested in how to ssh into nethserver interface:

Added red:

I then open ssh like this:

ssh -p MYPORT -L 9000:localhost:980 root@myserver

Then I can access the webinterface locally in the browser.


Don’t forget to change back the interface from “green,red” to “green”, which is VPN-only"

Again: thanks a lot.
Cheers, Axel

1 Like

Thanks for your feedback.
Are you still using the old web interface at port 980? I recommend to have a look at cockpit at port 9090.
You can mark a topic as solved instead of adding [solved] to the topic title, see Howto mark a topic as solved

1 Like

No, I am using the new interface . Indeed, this an old command. But the principle connection tho the local VPN interface ist the same :slight_smile:

Marked solved.

1 Like