Change Proxy port


(Josue) #1

Hello¡¡ Is possible change proxy port?

Thanks¡¡¡¡¡


(Filippo Carletti) #2

The squid web proxy port is hardcoded (3128).
I think that we have two ways to change it:

  1. modifiy the squid.conf
  2. redirect tcp connections

A better approach could be adding a “Port” field in the configuration page when the proxy is set to manual or authenticated.

I just tried option 1 and it works.
Commands:

config setprop squid TCPPorts 8080,3129,3130
mkdir -p /etc/e-smith/templates-custom/etc/squid/squid.conf/
sed "s/3128/8080/" /etc/e-smith/templates/etc/squid/squid.conf/40ports >/etc/e-smith/templates-custom/etc/squid/squid.conf/40ports
signal-event nethserver-squid-save

I think that this option need an issue to be discussed with others.
Would you mind opening it on dev.nethserver.org?


(Josue) #3

Lot of thank¡¡¡¡ work ok the commands¡

I think that it a very good idea, various ports separated by “,”

Thanks¡¡