Change from terminal trusted network

I have move my nethserver from 192.168 to another address 172.16 but I did forgot to change trusted network so now I can’t access cockpit.
How do I change that from terminal?

Green is trusted by default.

Show trusted networks (the default green is not shown here):

db networks show

Set a trusted network:

db networks set network Mask Description text123

Apply the changes:

signal-event interface-update

1 Like

Thanks for the fast replay
I did add and but still no access to cockpit.

Strange, have no problem to access with SSH or Ping the server.

Does cockpit start?

systemctl status cockpit -l

At some point did you set limited access to cockpit?

config getprop cockpit.socket LimitAccess

1 Like

Strange, it is inactive (dead)
Not sure why?

Are there errors in the status output?

You may try to start it:

systemctl start cockpit

When I run systemctl -l status cockpit.socket I can see it is Active (listening) but still no access.
Trying now and install a clean nethserver to see if it is something with my firewall.

I have no LimitAccess what I can see.

Hmm have now create a new server with Netsherver on my 172.16 network and is no problem to access cockpit to that server.

1 Like

A little update here
With my new nethserver I did change DNS did reboot nethserver and have no access to cockpit.
I did try with the IP address and I can see info om nethserver so I know it have access to the server.
I then did look at the status of cockpit
systemctl status cockpit
and it show it is inactive.
I then run
systemctl start cockpit
and run status again and now it show active but still no access to the cockpit and after a while the status show inactive.

I then run journalctl -u cockpit
but see no special error more then it does not like some certificate.

Then I did look inside /var/log/messages but even there I see no error about Cockpit

Maybe the DNS is not working.

To reset DNS to Google servers:

config setprop dns NameServers,

Apply config:

signal-event nethserver-dnsmasq-save

It did look first it working but after a while it can’t access cockpit and when I look status of cockpit it say inactive.

Not sure why it does not work, What I know only port that Cockpit use is 9090

I did find the problem.
I did forgot that when I move the server to my 172.16 network I still have to trust 192.168 so I can access cockpit when I use my computer that is on 192.168.

1 Like