Challenges in Email inbox in Webtop after Migration to VM

So over the weekend I did a backup of physical server in anticipation of a server migration from physical to vm. I tried to do a clone migration to vm with clonezilla. After many attempts, that didn’t work. So then decided I would do a fresh install of Nethserver in to XCP-NG VM. Install worked fine. So then I started the restore process in to vm from my backups. Every thing seemed to be ok. Until I look at my Webtop inbox and saw this.

All the other all emails and folders are correct and existing, but unfortunately the email(s) in the Inbox seem to be invisible. lol

I am unsure of how to make the emails visible at this point. I have looked around in Webtop to no resolve.

Any thoughts or any help would be appreciated.


Interestingly. My other users and the admin’s still have their email visible in inbox. Still trying to find an answer to why this is happening. I am looking in the backend. If I find something I will report if I find an answer.

I would guess someone else might have come across this issue in the past. If so let me know what your fix was. I appreciate and am thankful for any help.



In Webtop, every now and a long time I get a new email, but every other email in INBOX does not show up. Just has a number of how many new emails are in the INBOX.

I setup the email user in Thuderbird via IMAP, I was able to see all the older emails, but none of the newer emails.

I feel like the INBOX list of emails in the folder is corrupted. Does anyone know if Webtop 5 has an indexer or a rebuild tool for user emailbox?


Still having the same issue with my inbox. Although today I tried to reply to a incoming email and recieved the following.


I don’t understand what a closed folder is? Any ideas? Seems like the inbox is set to readonly or something. I am unsure of how to fix this. Any ideas?


@webtop_team , any idea on what @Shadowfire can check?

1 Like

Would it be possible anyone on @webtop_team to help me out. Your input is much appreciated.



Did you already check mail folder permissions?

# ls -l /var/lib/nethserver/vmail/<MAILUSER>/Maildir
drwx------ 2 vmail vmail  299008 Apr 10 00:20 cur
-rw------- 1 vmail vmail       0 Apr 18  2020 dovecot-acl-list
-rw------- 1 vmail vmail   81416 Apr 10 00:14 dovecot.index
-rw------- 1 vmail vmail 2812472 Apr 20 19:28 dovecot.index.cache
-rw------- 1 vmail vmail    1064 Apr 20 19:28 dovecot.index.log
-rw------- 1 vmail vmail   50320 Feb  1  2022 dovecot.index.thread
-rw------- 1 vmail vmail      42 Jun 19  2022 dovecot-keywords
-rw------- 1 vmail vmail     384 Oct 11  2021 dovecot.mailbox.log
-rw------- 1 vmail vmail  245916 Apr 10 00:20 dovecot-uidlist
-rw------- 1 vmail vmail       8 Mar  9  2022 dovecot-uidvalidity
-r--r--r-- 1 vmail vmail       0 Apr 18  2020 dovecot-uidvalidity.5e9a7
drwx------ 2 vmail vmail      58 Dec 28  2021 lucene-indexes
-rw------- 1 vmail vmail     176 May 10 05:01 maildirsize
drwx------ 2 vmail vmail       6 Apr 10 00:20 new
drwx------ 5 vmail vmail      74 Oct  8  2022 public
-rw------- 1 vmail vmail      40 Oct 11  2021 subscriptions
drwx------ 2 vmail vmail       6 Apr 10 00:20 tmp

@mrmarkuz Thanks for trying to help. I really do appreciate it.

Here is a ls -l of the directory on my side -

I don’t see a difference in permissions.

So let me add more to the issue. I am actually able to bring up the emails. But it is not a solution and very time consuming and frustrating. When I am in the email portion of Webtop5, in the inbox. It doesn’t show emails. If I start to click back and forth between the following folders, where the following circles are in the picture below enough times, the list of emails will come back at some point.

But even after the list shows up, if I am deleting, I can only delete one, then I have to go back through the clicking process again till it decides to list it again, because the list will disappear when I click back on the Inbox. Then I end up with the below picture.

It very strange.


Did you already test it with Roundcube Webmail? Just to see if it’s about Webtop…

Maybe the restore process was interrupted somehow?
You could try a selective restore of the mails, see Backup — NethServer 7 Final


@mrmarkuz I have not tested it with Roundcube webmail. Ah. I didn’t know that that was an option. I will look in to that and update you on what I find.


1 Like

Hi Jeff,
in addition to following @mrmarkuz advice (also test with Roundcube) I recommend analyzing the dovecot log (/var/log/imap) if it reports errors or relevant reports while the problem occurs.



Hello guys. Sorry, I got really busy and tied up with things. I took a screen shot of the /var/log/imap. See below.

I am also attaching the following screen shots. The error is from logging in.

I get the next one looking into the inbox clicking on an email

It definately looks like a permissions issue. I am not exactly sure what to do to fix it. It seems like INBOX folder may not have the correct permissions is what I get from the log file /var/log/imap

So I loaded Roundcube up and logged in to it. It seems that the email shows up fine in Roundcube. So it definitely seems to be a problem in Webtop 5.

Any thoughts on how to get Webtop 5 to display the e-mail inbox correctly everytime?



Okay. I take that back. After using Roundcube for a little bit, the email has dissappeared an the below picture is all I get, and it list how many emails are in the folder below.


id vmail
doveconf -n | grep -E '(uid|gid)'
ls -lash "/var/lib/nethserver/vmail/user@domain.tld/Maildir/cur/dovecot*"
ls -nash "/var/lib/nethserver/vmail/user@domain.tld/Maildir/cur/" |head

When it fails, can you look if some of the messages under /var/lib/nethserver/vmail/user@domain.tld/Maildir/cur/ have wrong permissions? You can look at logs and then just list permissions for one of the message file reported in the log.


Thanks for the recommnedation. I took a look at -


and found the following -

I chown the root ones to vmail:vmail.

I am testing now to see if it fixed the issues I was having.

@mrmarkuz @dnutan @lucag

I have been testing for a little bit now. So far it looks like that was the issue. Two files somehow got switched to root. I just switch them back to vmail and all seems to be working like it should.

Even the dovecot log / logs looks like errors for imap is cleaned up.

I think you guys helped me crack it.

Thanks guys! I appreciate all your help.