Cert for collabora vhost

System: NS7, NethServer-Nextcloud, Collabora installed via Yum

I have Collabora installed and working.

In order to connect to the Collabora virtual host a valid cert is needed.
I have obtained a LE cert for the virtual host and manually copied the cert info into the virt host .conf.

As well as I can see neither ‘setprop loowsd Domain’ or ‘signal-event nethserver-collabora-update’ attaches a cert to the virt Collabora server.

My problem is this:

What is the correct procedure to attach a cert to this virt server noticing that the Collabora virt host is a system host and not visible in the web GUI.

Thanks for an excellent product

Best regards

Please request a LE cert via server manager and add the wanted collabora virtualhost domain to the letsencrypt domains and set the letsencrypt cert as default. There’s no need to edit a .conf file.



Hi @mrmarkuz

Thanks for your answer.

The server already has three dedicated vhosts each with a LE cert attached.
Further the NS server itself has a LE cert, this one set as default

If I set the cert for collabora as default I will loose the cert for the NS which I would rather not.
Is there an additional.conf or custom.conf file where I can write the cert information?
If i keep the modified .conf file I risk it being overwritten by the webadmin.

Collabora itself has SSL disabled. Do you use collabora and nextcloud on the same host?

What’s the exact error message you get (screenshot) ?

As soon as you can reach Nextcloud correctly over HTTPS, collabora should work too.

If you use an own domain for nextcloud (virtualhost), add it to the default server letsencrypt cert.
Why using a separate LE cert for any virtualhost if you could use one LE cert for all?


I am not aware that LE is able to make SAN certificates.
That will off course change the game and make everything easier.

Will try that solution.