Can't start backup-data-cloud

backup

(Riccardo F Capra) #1

Hi, I have made all the hacking, but, how can I start the cloud backup?


Backup-data-cloud
Backup-data-cloud
(Giacomo Sanchietti) #2

Just execute:

backup-data

(Riccardo F Capra) #3

Not working…


(Giacomo Sanchietti) #4

Could you please check if are there any errors inside /var/log/messages?


(Riccardo F Capra) #5

It looks like it tries to mount a CIFS

Jan 9 12:40:52 posta esmith::event[14122]: Action: /etc/e-smith/events/pre-backup-data/S50nethserver-webtop5-backup SUCCESS [0.232193]
Jan 9 12:41:02 posta kernel: CIFS VFS: Error connecting to socket. Aborting operation. Jan 9 12:41:02 posta kernel: CIFS VFS: cifs_mount failed w/return code = -115
Jan 9 12:41:02 posta esmith::event[14122]: Action: /etc/e-smith/events/pre-backup-data/S70mount-cifs FAILED: 1 [10.206866]
Jan 9 12:41:02 posta esmith::event[14122]: Action: /etc/e-smith/events/pre-backup-data/S70mount-nfs SUCCESS [0.17238]
Jan 9 12:41:02 posta esmith::event[14122]: Action: /etc/e-smith/events/pre-backup-data/S70mount-usb SUCCESS [0.165375]
Jan 9 12:41:02 posta esmith::event[14122]: Action: /etc/e-smith/events/pre-backup-data/S70mount-webdav SUCCESS [0.172241]
Jan 9 12:41:02 posta esmith::event[14122]: Event: pre-backup-data FAILED


(Giacomo Sanchietti) #6

Exactly, did you configured also the CIFS destination?
If yes, the mount must work before proceeding.

This customized version of backup will try to execute the normal backup at first, then execute also the cloud backup.


(Riccardo F Capra) #7

The server is on the cloud. I tried with everything, but nothing worked. Now the autobackup is disabled, but it always tries to mount a CIFS


(Riccardo F Capra) #8

2018-01-09 15:14:23 - START - Backup data started
2018-01-09 15:14:48 - ERROR - Error while mounting xxx.xxxxxxx.xx:Nethserver : mount error(115): Operation now in progress Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
2018-01-09 15:14:49 - ERROR - Event pre-backup-data failed - 1


(Markus Neuberger) #9

You may have a look at the backup-data configuration in the web UI and check if the settings are correct and if you can connect to the share:


(Riccardo F Capra) #10

I don’t need any local backup, also because I don’t have the possibility to do it…


(Markus Neuberger) #11

What about using default backup via webdav?


(Riccardo F Capra) #12

I have troubles installing a certificate in my QNAP device.


(Giacomo Sanchietti) #13

Could you please post the output of config show backup--data?

Please bear in mind you’re trying to use a non-standard procedure, so you need to dig a little bit by your own.
On the same path, you could also try to use rsync for backup instead of the built one. You could take inspiration from this script:


(Riccardo F Capra) #14

backup-data=configuration
BackupTime=11:20
CleanupOlderThan=7D
FullDay=0
LogFile=/var/log/last-backup.log
Mount=/mnt/backup
NFSHost=tim.xxxx.xxxxxxxx
NFSShare=Nethserver
Program=duplicity
SMBHost=tim.xxxxx.xx
SMBLogin=admin
SMBPassword=xxxxxx
SMBShare=Nethserver
Type=incremental
USBLabel=localhost.localdomain:2
VFSType=usb
VolSize=250
WebDAVLogin=admin
WebDAVPassword=xxxxxx
WebDAVUrl=http://tim.xxxx.xx:80/Backup
notify=error
notifyFrom=posta@studioxxxxx.it
notifyTo=cxxxxxxxxxxx@gmail.com
status=disabled


(Giacomo Sanchietti) #15

You should be able to workaround the mount problem by executing this command:

config setprop backup-data VFSType ""

But I didn’t test it.


(Riccardo F Capra) #16

It didn’t work …

2018-01-10 17:48:34 - START - Backup data started
2018-01-10 17:48:51 - STEP - pre-backup-done done
2018-01-10 17:48:52 - ERROR - No valid VFSType (UNKNOWN) - 1
2018-01-10 17:48:52 - ERROR - Action backup-data-duplicity failed - 1