Can't share by link anymore

NethServer Version: 7.5
Module: nethserver-nextcloud
I just tried to share a file on ns-nextcloud, but was not able to share through a link.
Has something changed lately? I was able to share through a link before. (I currently even have a file shared through a link)

rpm -qa | grep nextcloud

I tried it and sharing by link works:

but there’s a newer version:

[root@server2 ~]# rpm -qa "*nextcloud*"

Nextcloud is running on a crostino subscribed server. When I perform yum update or even yum update nethserver-nextcloud, there are no packages marked for update.

What’s missing, the “Enable” checkbox or the link?

Does it work if you get the “Copy URL” via “Shares” instead of “All files” in the left menu?

Copy link is possible, but that is only usefull for those that have access to the directory, which is only me. That defies the sharing bit a bit…

Here you see I can share through Name or email address. But no option to share as link…


Again, I was able to share through link before but it is not anymore and I have no clue what happened and when this changed.

I only can reproduce it when I turn off “Allow users to share via link” in the Administration settings:

1 Like